Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I don't know if I am going to get an answer or if this is possible but here goes.

On my old macbook pro, running Snow Leopard, I installed Windows 7 with bootcamp. The logic board crapped out on me so I bought a new Macbook Pro running Lion. I took the old hard drive, with my windows 7, out and put it in an enclosure. So now I am using it as an external hardrive.

The problem is I can't find my CD Key for that install of windows. I know how to get the CD Key when Im on Windows but I don't know how to boot it up again. I only have a USB connection on the external HD.

Here is what I have tried so far:

I tried to boot Windows by plugging in the external HD by USB, restarting and holding option and then selecting it at the boot menu but I was unable to boot it. The windows icon started at the beginning but it said something about it not being installed on the original computer or something. I will have to try again to give you guys a more accurate analysis.

Is there a way to get the product key in my situation or am I screwed?

Thanks

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Windows won't simply boot from an external HDD. Do you have it installed via Boot Camp on your new Macbook? If so, use that or another PC running Windows, connect your external hard drive with the old OS installation on it and run ProduKey:

1

If you go to File / Select Source, you'll see a whole lot of useful options there:

2

share|improve this answer
    
I will try that and let you know how that went when I get home today. Thanks for the reply. –  JoeMoe1984 Jan 23 '13 at 20:58
    
Awesome, I think it worked. Only way to test it out is if I got the right product key or not. Here is what I had to do to make sure it worked as it didn't just work right away. I plugged in my External into a Windows 7 PC. Installed the ProduKey, but it didn't work. So I tried the Command Line tools and that didn't work either. I had to open Command Prompt as admin and I CD into the directory with the ProduKey program and typed in this command - ProduKey.exe /regfile "E:\Windows\System32\config\software" (E: being the directory of my external) and that worked for me. –  JoeMoe1984 Jan 24 '13 at 18:42
    
Possibly you could have run ProduKey as admin as well, and I always use the portable version. Anyway, glad it all worked out for you. :) –  Karan Jan 24 '13 at 18:47
    
Yeah probably, but I was already in the mood to use the Command Prompt ;) –  JoeMoe1984 Jan 24 '13 at 18:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.