Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm sorry for the long question, but I wanted to make sure it got the point across.

The thing is, that no matter what I do, when I use a linux-based console application that uses ncurses, via SSH from Windows, is rendered incorrectly.

I have tried changing the encoding of the SSH client, I have tried installing different fonts (that I know contain the characters used by ncurses), but nothing seems to help.

As a reference, this is what is supposed to be displayed: (This is a connection from Linux machine)

And this is what I get when I connect from Windows (using Bitvise SSH client):

Of course, different encoding settings and different font types produce different results, but they all look wrong. I've also tried using PuTTY with similar results.

I personally think it's a font problem... What do you think?


Edit 2013/1/19 12:51am

I just tried it from my Mac and guess what? It works as expected. There are some minor glitches, but the output from toilet, moc, elinks, libcaca, etc... look just about right:


Edit 2013/1/19 3:02am

Well, whatever the problem, it's not affecting Haiku!


Edit 2013/1/19 3:02am

Eureka! The problem? The font, just as I suspected.

After trying a countless set of fonts I've finally found one that is capable of properly rendering an SSH session where an application uses ncurses!

The font is the DejaVu fonts. Unfortunately, installing them is not enough; to make these fonts available on the Windows' command prompt you will need to either manually edit the registry or, if you prefer, use this little app I created: Command Prompt Fonts.

Whatever method you use, once you have assigned this font to the Windows' command prompt, you should be able to properly emulate xterm:

share|improve this question

migrated from stackoverflow.com Jan 19 '13 at 8:11

This question came from our site for professional and enthusiast programmers.

    
Try to change the option "Use Background Colour to erase screen." in PuTTy (options)->(Terminal) In the server: export NCURSES_NO_UTF8_ACS=1 –  Ricardo Ortega Magaña Jan 19 '13 at 3:08
    
@duskwuff: Yes. I said so in the OP. –  xfx Jan 19 '13 at 3:15
    
@RicardoOrtegaMagaña: That doesn't seem to make any difference. Here's a screenshot using PuTTY –  xfx Jan 19 '13 at 3:16
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.