Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm trying to get KeePass (v2.20.1) running with Mono (v2.10.10) on my Mac running OS X 10.8.2

The KeePass that I've downloaded from http://keepass2.openix.be is NOT a KEEPASS.EXE file as mentioned in earlier posts above, but seems a Mac application and when clicked states something like:

You have no permission to open Keepass 2.20.1" ( I have a Dutch interface )

I've tried running the Windows .exe but without result, can someone tell me how I can get KeePass running on my Mac?

share|improve this question
    
Any reason for not using KeePassX? –  slhck Jan 19 '13 at 12:10

3 Answers 3

It seems the developer made a mistake when creating the disk image for KeePass for OS X. Your user does not have any permissions for the application bundle to run it or copy it off the disk image.

Remove anything you might have already copied first. Then, after you mount the image (and see the "To install, drag …" instructions), open Terminal, and enter the following:

sudo cp -r /Volumes/KeePass2.20.1/KeePass2.20.1.app /Applications
sudo chmod u+wrx /Applications/KeePass2.20.1.app
sudo chown -R $( whoami ):staff /Applications/KeePass2.20.1.app

You'll get asked for your password after the first command. You need to be a computer administrator to perform these steps.

share|improve this answer
    
Thank's for your input, and it took me a bit further. I now have a KeePass2.20.1.app file in the applications folder that is 4.x Mb large ( the old one was 0kb ) but when I try to run it, it seems to start, but then does nothing. I tried running it from the Terminal by entering mono keepass2.20.1 and some variations on that, but no result. Any more ideas / suggestions ? –  Robert Jan 19 '13 at 15:41
    
@Robert It's a Mac application bundle, i.e. a folder that only looks like a file in Finder. You can right-click it and select Show Package Contents to view the contents in Finder. You can see the actual mono call in KeePass2.10.1.app/Contents/MacOS/startkeepass.sh, which is in the same folder where KeePass.exe and all auxiliary files reside as well. –  Daniel Beck Jan 19 '13 at 16:11

I was facing problems with running the keepass bundle downloaded from openix.be (I've tried on Mac OS X Snow Leopard - 10.6.8). The only way to run the original keepass on Mac was to download Mono framework (www.mono-project.com) for Mac, download the latest keepass.exe from the original site (http://keepass.info/download.html) by selecting the portable .zip package, decompress the .zip on my mac, and run "mono keepass.exe" from the Terminal application.

Unfortunately I've found some problems with copy-and-paste, which is not currently supported in mono for Mac. In the latest version (2.22) the "copy password" button works, but any other function based on copy-and-paste (i.e. Cmd-C / Cmd-V) will not work.

I resolved my issues by using KeepassX (version 2.0 alpha 4), which appears to have less functions, but is natively integrated in OsX and copy-and-paste works as expected.

share|improve this answer

I had the same problem, until I found out that preventing KeePass to connect to the Internet (via firewall) solves the issue. Now it starts and it stays open. Give it a try.

share|improve this answer

protected by Community Jun 6 '13 at 23:37

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.