Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have installed Linux Mint 14 Nadia on a machine with an oldish ATI graphics card the "Advanced Micro Devices [AMD] nee ATI RV370 [Radeon X550]" It used the free drivers on install default and I have tried to get it to use hardware acceleration so went to the AMD site and downloaded the "ati-driver-installer-9-3-x86.x86_64.run" which apparently was needed for this card, however, when I try and run the driver it gives this error -

 Error: ./default_policy.sh does not support version 
 default:v2:i686:lib::none:3.5.0-17-  generic; 
 make sure that the version is being correctly set by --iscurrentdistro

and if I do

 ./ati-driver-installer-9-3-x86.x86_64.run --listpk 

I don't see my version? So I kind of installed the "wrong" version and now it doesn't look to good It seems to me that AMD are not supporting older cards on later releases? Is this true and if so how do I get it working?

share|improve this question

1 Answer 1

up vote 1 down vote accepted

That is because you need legacy drivers for your old care.

But I wouldn't suggest you to go and download from ATI, but to find package for Linux Mint. Maybe you will find this post helpful.

If you really insist on AMD installer, you can try this, but first you have to downgrade your X server (you won't lose any new features with that because X didnt't publish any new features since 2001, I guess).

share|improve this answer
    
I am very happy with any advice, I wont do anything in haste as I have a quite a work backlog to do –  peterretief Feb 26 '13 at 15:37
    
The correct package for that card should be available in the Mint repositories. Search Software Manager and understand you may have to use the i386/i686 driver. There are still problems with x86_64 drivers for that generation ATI hardware. Only the 32-bit may be in the repository. –  OCDtech Feb 26 '13 at 16:37

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.