Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have recently setup a fedora 17 machine with Gnome and installed Mysql using the add/remove software GUi included. Mysql seems to be working - I can login, select databases, do queries etc but if I try to stop/start or get the status of the service in a teminal I get this:

#service mysql stop
Redirecting to /bin/systemctl stop  mysql.service
Failed to issue method call: Unit mysql.service not loaded.
[root]#service mysql start 
Redirecting to /bin/systemctl start  mysql.service
Failed to issue method call: Unit mysql.service failed to load: No such file or directory. See system logs and 'systemctl status mysql.service' for details.

[root]# service mysql status
Redirecting to /bin/systemctl status  mysql.service
      Loaded: error (Reason: No such file or directory)
      Active: inactive (dead)

Why? I'm trying to get Mysql workbench working.....

share|improve this question

If mysql was installed successfully, it should start with:

service mysqld start

The error message is confusing as it doesn't explicitly tell that you typed it wrong.

share|improve this answer

The following should show you if you have the service installed:

systemctl status mysqld.service

(try "yum install mysql" if not.)

That will also tell you if it's enabled. If not:

systemctl enable mysqld.service

That enables starting on reboot. (You don't HAVE to do that.)

systemctl start mysqld.service

will start it for you.

share|improve this answer

Simple, the service's name is mysqld, not mysql!

so all commands just need one mode character


service mysqld start

systemctl start mysqld

chconfig mysqld on

systemctl enable mysqld

share|improve this answer

as far as I know, MySQL is replaced with its fork MariaDB

so following commands will probabily work on CentOS 7 and other same versions:

systemctl stop mariadb.service //Stop MySQL Service

systemctl start mariadb.service //Start MySQL Service

systemctl restart mariadb.service //Restart MySQL Service

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.