Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

One script i used for years on production machine, stopped working after a linux system re-installation. after days of digging it turned out that the special variable IGNORECASE=1 has no effect.

I tried it for simple matching from the terminal, in a simple script and on the command line with -v but it is simply not working.

The system re-installed is the same we had before where every thing worked. same distribution, version, 64. every thing. just re installation.

any one had such thing before ?

share|improve this question
    
Weird... same gawk version too I imagine? Has there been no update in the meantime? The variable works as advertised on my LMDE, GNU Awk 4.0.1. –  terdon Jan 20 '13 at 0:45

2 Answers 2

Yes, something is wrong with the awk binary shipped with ubuntu 12.04 64.

I recompiled awk from source, the original script worked without modification.

share|improve this answer

Same for Xubuntu 14.04, by default it has a non-GNU version of awk, IGNORECASE is a gawkism. Solution is to install gawk, it replaces awk and your scripts will work again.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.