Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

A Fujitsu KB910 USB keyboard connected to a Dell XPS 8300 used to work flawlessly. But it then started to be unresponsive now and then on BIOS level, i.e. it was no longer possible to enter the user password into the BIOS entry screen. Pressing the power button of the PC was the only way to get it working, and it worked in 100% of all retry cases.

What could be the reason?

I have tried to use other USB ports, reset the BIOS, etc. The keyboard gets power via USB as indicated by the Num-Lock LED. The outages occured in about 10% of all starts.

Edited:

The problem also occured with a Cherry keyboard. Therefore, it seems to be the Dell XPS 8300. I removed all USB-related entries from the BIOS list of boot devices. But this does not seem to help.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Do you have anything else connected to any of the other USB ports? This may be a case of flawed power distribution.

I'd try the following: disconnect everything BUT the keyboard. That includes any memory card (such as SD and MMC). Make sure you have no USB hubs connected - connect the keyboard directly to the machine. Now try using it after a reboot.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.