Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have H61M-ITX board with 1 x PCI Express 3.0 x16 slot (blue @ x16 mode) http://www.asrock.com/mb/Intel/H61M-ITX/

I wan to install there PCI Express x 4 card: http://dektec.com/Products/PCIe/DTA-2144/index.asp

I made clean Win XP SP3 install + all MB drivers on top. After I inserted pcie x4 card and boot up. Win XP didn't detect the card (though leds on card are blinking periodically)

I then tried LAN adapter I have (to check if all is fine with MB). I took this one: TP-Link Gigabit PCI Express Network Adapter TG-3468

same behaviour - system doesn't see it but if i plug eth cable then leds on lan card blink.

please tell me what is wrong i do? I checked bios for anything related to PCIe and found nothing.

share|improve this question
    
Please tell me what I do wrong?. Other than installing XP in this day and age? Nothing. It should work. Can you check three things and add them yo your post? 1) Does the DTA2144 card work in another system (debug goal: card is not broken). 2) Does another card work in the ASROCK board (debug goal: the motherboard or connector is not broken). 3) Any known BIOS problems with the ASROCK and non graphical cards? (Sadly, while the standard tell us it should work, many manufacturers ship broken designs which only accept a GPU card in a X16 slot. –  Hennes Jan 20 '13 at 12:54
    
Additional debug options: Bot FreeBSD (or similar OS like a GNU/Linux liveCD) and look for the card with pciconf -l or `lspci'. Showing up in those would mean it is not a hardware problem (neither from the card nor the motherboard). –  Hennes Jan 20 '13 at 13:36
    
Please don't cross-post the same question on multiple sites. This question just is not on topic for Server Fault. –  Daniel Beck Jan 20 '13 at 14:34
    
2Hannes: Win XP. It is more familiar to me than fancy win7. but actually does it matter? 1) i assemled this pc ot check this DTA2144 card as it has strange behaviour (other PCs don't detect it).2) But i use two network PCIe-x4 LAN cards to check PC i assemble by itself. these two cards worked in other machines before 3) haven't check. i already posted bug report at Asrock website. still no reply. 4) lspci doesn't show any of pcie cards (DTA2144 and NEtwork cards) in the list –  alex Jan 20 '13 at 21:39
    
2 Daniel. Sorry. Noticed that. But it was late already –  alex Jan 20 '13 at 21:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.