Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I recently installed Fedora 11 on a Dell Inspiron 14. I think it uses a Dell 802.11b/g Wireless LAN. Windows Vista can detect it but Fedora 11 can't. How can I fix this?

share|improve this question
    
What is your network card? –  harrymc Oct 11 '09 at 14:14
    
what model of inspiron? –  quack quixote Oct 11 '09 at 14:33
    
Inspiron 14. How can I determine what my network card is? –  Randell Oct 11 '09 at 14:55
    
What driver does Windows Vista use with this wireless card? –  fpmurphy1 Oct 11 '09 at 15:45
    
@fpmurphy, how can I determine that? Can it be found somewhere in dmesg? –  Randell Oct 11 '09 at 16:02

2 Answers 2

Try to connect wired first, then get latest system/driver updates from Internet. It worked me few times.

There's a network manager called wicd, did you try it? And check linuxwireless out, you can find the other managers and lots of information about wireless.

share|improve this answer
    
Yes, this is what I'm gonna do. I'll post the results later. –  Randell Oct 11 '09 at 23:31
    
The update didn't solve the problem. –  Randell Oct 12 '09 at 4:59
    
try wicd too, one of my notebooks works only with it. –  buba Oct 12 '09 at 16:11
    
@buba, what's the model of your notebook the works with wicd? –  Randell Oct 13 '09 at 10:19
    
hp pavilion dv5000 with amd sempron, it has ubuntu 8.10; i haven't tried with newer versions of ubuntu. –  buba Oct 13 '09 at 21:54
up vote 1 down vote accepted

I finally made it work! I followed @emgee's lead and used lspci. Executing lspci on my terminal showed this line along with several other lines:

0c:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g (rev 01)

Googling BCM4312 lead me to Broadcom Linux STA Driver. As stated in the intro:

These packages contain Broadcom's IEEE 802.11a/b/g/n hybrid Linux® device driver for use with Broadcom's BCM4311-, BCM4312-, BCM4321-, and BCM4322-based hardware. However, this driver is known to support other chipsets labelled differently (such as the BCM4328.)

And then it was as simple as executing the following:

Install the broadcom-wl packages

yum install broadcom-wl

Loading the driver

modprobe wl

and restarting my machine.

share|improve this answer
1  
Special thanks to @buba for following my progress. –  Randell Oct 19 '09 at 8:14
    
Congratulations, I'm glad for you :) –  buba Oct 19 '09 at 18:10
    
Do you know if I could do that in Ubuntu? Or what the commands would be? –  The Green Frog Mar 2 '10 at 15:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.