Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My company forces Active Desktop upon everybody so that it can display a (monthly-rotated) corporate wallpaper.jpg.

Problem is, some computers (including my laptop) somehow experienced some errors resulting in the dreaded "Active Desktop Recovery" screen to show up... and clicking the "Restore My Active Desktop" button always resulted in "Internet Explorer Script Error".

Various workarounds I found in the Internet either does not work or requires me to change the theme first to something else... and the latter I can't do because the Desktop Settings screen is locked via GPO.

As it happens, due to the nature of the programs I use, I'm granted Administrator-level access on my computer.

The question is:

How do I fix my situation?

Note: I don't need to put on my own wallpaper, but watching the "Active Desktop Recovery" screen (with its BLANK WHITE!!1! OH MY EYES!1!!one!eleven!! background) gets tiresome. I'm quite happy with the corporate wallpaper. I just need to somehow 'recover' my Active Desktop.

More information:

  • OS: Windows XP Professional SP3 (yeah, company's too afraid to even experiment with Windows 7)
  • Antivirus: Symantec Endpoint Protection

If you need any additional information, feel free to ask.

share|improve this question
1  
Been there. Both as a user and as admin who needed to fix it. I never figured it out, despite spending half a day on it. Every single solution seems to result in other errors or in no result. I ended up re-imaging the whole laptop. That still bugs me half a decade later. –  Hennes Jan 20 '13 at 16:16

3 Answers 3

up vote 0 down vote accepted

Being this is a GPO issue have you thought about just asking IT to fix it? Being domain admins they can do things like temporarily turn off your GPO rules and get it fixed a lot easier than you your self could.

I know as a techy myself it can be hard to just ask somone else to fix something for you on your computer, but sometimes you just got to go IT and get stuff fixed.

share|improve this answer
    
sigh ... that means, the recovery has to wait until I get back at the office... oh well :/ –  pepoluan Jan 20 '13 at 19:33

on Desktop right Click then properties in desktop tab click customize desktop then untick any checkbox then ok and apply and repeat again this task

share|improve this answer
    
I wrote in my question: "... the Desktop Settings screen is locked via GPO." –  pepoluan Jul 3 '13 at 7:45

Workaround: Right click anywhere on the desktop, choose Properties.

On the Desktop tab, just click a different Background then click the original (corporate) one. Windows will think you made a change (although you didn't) so the Apply button becomes active. Hit it (or the OK button), message will be gone.

Other (suggested) solution: Open Regedit, drill down to HKEY_CURRENT_USER\Software\Microsoft\Internet Explorer\Desktop\Components and set the value for DeskHtmlVersion to 0.

That last one didn't work for me because after a restart (or logout/login), the value was back to 0x00000110 (272).

Do you have your system set to automatically log you in? I do, and see the white screen occasionaly, too.. maybe twice a week. If you really need the auto-logon, use the workaround above (just 6 mouse clicks).

share|improve this answer
    
unfortunately, that menu had been disabled via GPO. So I really can't change it via menu. BUT... your registry trick might've worked. The 'problem' is that I've left Windows XP and is now using Windows 7, which up to now has not (yet) had the problem :) –  pepoluan Nov 27 '13 at 8:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.