Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an odd issue with my new Windows 7 laptop, and I'm at a loss to explain it.

I was listening to a podcast downloaded to my hard drive (incidentally a StackExchange podcast) while I did the dishes this morning, with the laptop on battery power with its lid closed. The podcast played perfectly.

I finished the dishes before I finished the podcast, so I carried the computer, under my arm, back to the living room. As I was travelling, the podcast cut out. I thought it was an issue with the application (Media Player Classic), but another test with YouTube seemed to confirm something was going on. I tried with both the podcast and a YouTube video playing, and the podcast cut out a couple seconds before the YouTube video.

Through some of trial and error, I've narrowed down the reproduction steps:

  • The computer must be on battery power. The sound returns almost immediately when I plug the computer back in, and doesn't disappear at all when plugged in from the beginning.
  • The laptop must be in a "carrying" position. For example, from a seated position, I close the laptop normally and then tilt it so that I'm looking at the underside of the machine.
  • The laptop lid must be closed. I tested with tilting the laptop while still open, and no loss of functionality occurs.
  • The sound (at least) cuts out after about 12 seconds.
  • If I simply leave the machine still, the sound resumes after a few seconds. When I walk around with the laptop closed, the sound stays gone.

I'm not sure what exactly is happening during the outage, since the only indicator I have is the sound. I tried a couple things to make sure the rest of the computer was still working, like running a script to print a countdown on a one second timer (which seemed to still count down during the outage). I even started a virus scan before a test once to test for a hard drive issue (results inconclusive: the drive felt like it was spinning, but without an accurate before/after count, made impossible by the 12 second delay, it's hard to tell, though it seemed like it successfully scanned things).

I'm at a loss to explain what could be causing this:

  • I thought it could be a power settings issue, since it only happens on battery, but then why does the laptop need to be tilted? Also, I examined the advanced power settings and nothing jumped out as a possible suspect.
  • I suspected a hard drive issue, thinking a loose connection could cause issues when the laptop is tilted, but then why does it only happen when the laptop is closed and under battery power? Why does the problem only last for a few seconds rather than intermittently? Why doesn't Windows blue screen?

It's a refurbished computer, so there's certainly the possibility of a hardware problem. However, this is the only issue I've encountered in the week or so I've had it.

Any suggestions would be greatly appreciated.

share|improve this question
add comment

2 Answers

It turns out this was the hard drive trying to protect itself. A friend suggested that the laptop drive might have an accelerometer installed, which is a device designed to pick up changes in acceleration and g-forces to detect when the drive is falling, in order to pull the read/write head away from the platter to try to prevent damage to the drive.

After a bit of searching, which embarrassingly led me to realize I'd overlooked a control panel option specifically having to do with this feature, I was able to temporarily disable the accelerometer in order to try to reproduce the issue. With the accelerometer disabled, there was no interruption to my test audio (the same podcast from earlier).

Clearly the accelerometer was the "issue", though I'm not sure why it only activates when the lid is closed. Surely a laptop can fall off a table while open as well, right?

Either way, case closed.

share|improve this answer
add comment

The WiFi antennas are most likely in the lid. If you close it, re-orientate them (put it under your arm), and then move them, I'd bet you are probably just interrupting the WiFi.

The longer/farther you move it the lengthier the interruption, and if it's long enough the stream won't be able to resume.

You could test it a bit furtherer by opening a command prompt (cmd), and starting a ping test to your router (or some place on the internet), something like ping 192.168.1.1 -t or ping www.intel.com -t.

This will start a non-ending ping test (you can stop it with ctrl-C).

This can show a couple things:

  1. If the ping test freezes/stops updating during moving, then you've probably got a hardware problem (drive, MB, RAM, etc.).
  2. If the ping test keeps going, but during the period where you moved it it reports something like "Request timed out" or "Host unreachable", then you now it's the network being interrupted.

If it is just Wifi drop out, then to fix it, you'll probably have to do something to get the signal up in that area of the building (like moving you wireless router/access point, get better antennas for it, get a repeater, or another WAP, etc.).

Note: this all assumes that all power saving features of Windows and your notebook have been disabled for when you close the lid.

share|improve this answer
    
This isn't a wireless issue. The podcast is a downloaded file on my hard drive. I mentioned the issue to a friend of mine, and he suggested it may be an accelerometer issue. I'm trying to figure out how to disable it on this machine (HP laptop with a Toshiba HDD - tricky to know which utils are kosher) to test it. –  AgentConundrum Jan 20 '13 at 18:00
    
Yeah, the fact it was a pre-downloaded Podcast and that no internet was involved would have been a nice thing to put in the question. ;) –  techie007 Jan 20 '13 at 18:02
    
It would have, definitely. Unfortunately, it didn't even occur to me until I saw your answer. I always download podcasts - at least the SX one - since I have Firefox's click-to-activate plugin thing on, and it's still a bit glitchy. –  AgentConundrum Jan 20 '13 at 18:04
    
The accelerometer may very well be what's going on. You won't be able to disable enough Toshiba utilities to hurt anything. Perhaps try Safe Mode, or temporarily disable things via MSConfig. Often the accelerometer utility will pop up and tell you it's activated. Does it do that when you have the lid open and move it around? –  techie007 Jan 20 '13 at 18:05
    
I added the downloadedness to the question. As for utilities, I'm still trying to figure that out. I'm a paranoid sort when it comes to these things. :) –  AgentConundrum Jan 20 '13 at 18:06
show 2 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.