Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

FTP transfers (using for example FileZilla, CrossFTP or AnyClient) keep corrupting my files that I download.

  • I know it's not corrupt at the server level because other people can download it without any problems.
  • The file is an ISO but it also has corrupted RAR.
  • I have been able to download AVIs and everything would be fine.
  • I tried using FileZilla, CrossFTP and AnyClient, and I got the same results.
  • I tried opening the file with 7-Zip, WinRAR and Virtual CloneDrive, all gave me error messages when opening.
  • I tried downloading with "Binary" and not "Auto", same result.
  • I am not stopping the download and resuming it, so that's not the problem.
share|improve this question
1  
I assume the AVI file format allows for some corruption without you noticing it. So: maybe you are having the same problems for AVIs. Is this on multiple sites, or is it just one download site that is giving you trouble? –  Arjan Oct 11 '09 at 14:13
    
Was the file, perhaps, damaged in UPload? –  Phoshi Oct 11 '09 at 14:17
    
I suppose that could be true about the AVI. I dont really have any other ftp sites to try. Maybe I will hp.com. Phoshi, other people can download the file and not have issues ;) –  thegreyspot Oct 11 '09 at 16:14
1  
And what about other ISOs? The "it also has corrupted RAR" is a bit vague to me. Just once, quite often, all the time? No warnings from virus scanners that claim to have removed something? –  Arjan Oct 12 '09 at 6:51

5 Answers 5

up vote 1 down vote accepted

It ended up being a problem with Comodo Internet Security. It was not letting the "continual connection to the ftp server" stay connected. However the transfered continued, it still curopted. Either turn off Comodo Firewall, use ftps (Secure FTP, it has 100% integrety checking), or see if the solution ends up here at my comodo forums topic

share|improve this answer
1  
Thanks for reporting back! –  Arjan Oct 22 '09 at 6:39

I had multiple cases where my usual FTP-Clients (e.g. ncftp) corrupted the files during the download. But FireFTP, worked fine in those cases, too. However, I still don't know what the real reason was (explanations welcome).

share|improve this answer
    
Maybe FireFTP was using different network settings? (Firefox always used its own settings for any proxy server, and since 3.5 optionally can use the system wide settings as well.) –  Arjan Oct 11 '09 at 14:31

Some hypotheses, each more unlikely than the other:

  • Files already corrupted on the server,
  • Bad FileZila installation,
  • Bad sectors on your disk.
  • Bad network card or router (EDIT)

You can test each one in turn.
If none works, that's as far as my imagination goes.

share|improve this answer
    
s/than the other/than the previous/ –  quack quixote Oct 11 '09 at 14:23
    
Same for CrossFTP, so you can tick FileZilla of that list. –  Arjan Oct 11 '09 at 14:32
    
Ya like Arjan says, CrossFTP and Anyclient both have the same problem. Other people can download the same file and have no problem. Bad sectors not possible because I tried on two different drives, one being only 3 months old :) –  thegreyspot Oct 11 '09 at 16:05
1  
If it's not software and not the hard disk, then might it be your network card or router? –  harrymc Oct 11 '09 at 16:40

I had this problem a few years ago with opening any RAR files. From my understanding that seems to be a part of your problem. My problem was that I had a bad stick of RAM that was corrupting the file as it was being decompressed. Maybe run some diagnostics on your RAM or attempt to open the downloaded file on another computer. That would eliminate the download error portion.

share|improve this answer

You need to upload the files in binary mode via ftp.

share|improve this answer
2  
Care to give more than a one-liner? eg how to do that? –  Andrew Nov 28 '12 at 11:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.