Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I'm trying to run a headless install of Dropbox on RHEL 6. The daemon seems to be running, but when I try to use Dropbox's associated dropbox.py tool to control the daemon, it fails to run with the following error:

Traceback (most recent call last):
  File "./dropbox.py", line 26, in <module>
    import locale
  File "/usr/lib64/python2.6/locale.py", line 202, in <module>
    import re, operator
ImportError: /home/dropbox/.dropbox-dist/operator.so: undefined symbol: _PyUnicodeUCS2_AsDefaultEncodedString

I'm running the current RHEL build of Python 2.6:

root@cedar [/home/dropbox/.dropbox-dist]# rpm -qv python
python-2.6.6-29.el6_3.3.x86_64

(I'm not sure if this would be better suited to Stack Overflow since it is on the verge of being a programming issue, but since I'm trying to use a program straight from Dropbox, I placed it here.)

share|improve this question

I had placed dropbox.py in the .dropbox-dist folder. When I moved it out of that folder, it seems Python no longer ran into a conflict with operator.so. So far as I can tell, this resolved the issue.

share|improve this answer
    
Worked for me, once I moved it out, the script worked. Just moved it up one level and voila. Nice one. – user328837 Jun 3 '14 at 3:08

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .