Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Before I added an Ooma phone to my home network, I could get to other machines on my network by typing "\dadscomputer\dadsfolder", for instance, if that folder was shared. Now, if I want to do the same thing, I need to type "\172.27.35.115\dadsfolder". That works, but it's a pain. I know I could make shortcuts, but as I add shares, I'd need to maintain those, and if IP's change I'd be hosed. Seems like I should be able to get local name resolution to work, by hostname.

BACKGROUND: Earlier, when it worked, I had:

[modem] > [switch] > [Windows XP computers]

Ooma (voip box) suggested that for quality of service concerns, I connect it like this:

[modem] > [ooma] > [switch] > [Windows XP computers].

I'd like to leave it that way, since that's the most reliable set-up for voip (no big download or upload would cause a telephone call to be messed-up).

So the ooma gets it's IP from the modem (192.x.x.x) and the Windows XP computers get their IP's from the ooma device (172.x.x.x).

Name resolution on all the computers on the network used to work before ooma, and the XP machines' configs have not changed. What certainly changed is now the ooma device is managing DHCP and, according to the menu on the device web interface, it's also handing DNS (but that might be for external name resolution). I searched every option in the menu tree of the device, but can't find anything to change.

Given that, for what ever reason, the ooma isn't helping with my local lan name resolution, what can I do within the Windows XP configuration screens to get name resolution to work? By the way, I never had any kind of "master/slave" relationship on my home network because there's never one machine that's turned on all of the time. But it seems to me there was some kind of workgroup or something that maybe allowed name resolution?

share|improve this question
add comment

1 Answer

Just to check your ooma device should be releasing IP addresses from private IP blocks for DHCP from 172.16.0.0 - 172.31.255.255. If they're using 172.x.x.x addresses outside that range the network broadcasts won't be working properly (http://en.wikipedia.org/wiki/Private_network), which is how they discover each other for name resolution. You could try using a more commonly used private range 10.x.x.x to see if that helps at all.

I recommend you have a look at this excellent TechRepulic article on the subject:

How NetBIOS name resolution really works

share|improve this answer
    
Thanks snowdude. My DHCP assigned IP is 172.27.35.113 on this machine, so at least the default is in the private IP block. I think the Ooma just does a bad job of managing Windows machines. –  Dale Mar 2 '13 at 0:04
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.