Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In Windows 8 when I try to delete folder I get the message:

The action can't be completed because the folder or file in it is open in another program

I check and close all program, I don't see it in the task-manager (if I reset the computer, and try again it will delete it)

Another problem in Windows 8, when I copy, or delete folder - I can't see the action until I press F5 for refresh how I can fix those problems?

share|improve this question
    
Did you try from an elevated command line (Run as administrator), del /f filename ? –  Ofiris Jan 21 '13 at 7:38
    
Use Unlocker to check which process has the file opened. filehippo.com/download_unlocker –  DragoonHP Jan 21 '13 at 8:51

3 Answers 3

up vote 9 down vote accepted

You can use command line utility Handle by Microsoft Sysinternals. It can tell you which process holds file or directory open, like this:

handle c:\mydir

This will show which process holds directory open, if any.

You can also use Process Explorer, but you will have to search for your file/directory using Process Explorer UI.

While this works, I still find it too complicated, because I use Far Manager all the time, and FAR is helpful enough to show list and offer to kill processes that hold my files open if I am trying to delete them using Far Manager interface.

share|improve this answer
1  
+1 Far Manager? Very fancy. –  deed02392 Dec 10 '13 at 16:03

This is often because Windows search index is being updated. Try the following:

In File Explorer, right-click on the offending folder. Choose 'Properties'.
Make sure you are viewing undr the 'General' tab, and click Advanced.
Untick box 'Allow files in this folder to have...' etc. (if it's not ticked when you open Advanced Attributes then this suggestion is the wrong one for you...) and click OK.

Try to delete the folder again. (if unsuccessful, then this suggestion is the wrong one...).

Click 'Advanced' again, and re-tick the 'Allow files in this folder...'etc. Click OK and close the Properties window.

share|improve this answer
    
Worked for me, thanks. –  Zachary Schuessler Jul 17 '13 at 16:26

Lockhunter is the program I use to handle this issue. Please note, I am on Windows 7, and it doesn't claim Windows 8 support, although it can't hurt to try it out. It will use a GUI interface to tell you which process is locking a file, and offer to kill it and delete the file.

Also, it adds a context menu option, which makes access to this functionality quite easy.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.