Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I am trying to use Amarok on multiple machines with one database. I've found only few information about it, but some say it is possible. What I've done so far is:

  • Dumping my local mySQL database for amarok
  • Setting up mySQL on a server and writing the dump into it
  • Changing the Amarok options, pointing to the new DB
  • Mounting my music folder in the same path on all machines
  • Setting the folder as local music folder in the settings on all machines

This works partially. Some statistical information appears (number of played tracks) and the playlists I once saved to the DB are there. I can even play them. The thing that isn't working is, that the tracks in my library (under Local Music) are gone. I even tried to rescan but it doesn't affect the other instances.

Has anyone experience with this? Is it even possible to do?

Update

If been fiddling around a little with rescanning. I noticed that when I freshly write my dump to the new DB, the library on the client where I created that dump seems fine. My guess is now that it has some kind of client ID. I'm not sure though it still shows strange behaviour across clients if I start rescanning. I've looked through all Amarok related files in ~/.kde/ (at least I think I got everything) but I can't seem to find something relevant.

Update

After some experimenting with the config file I copied all of them from the first client. I copied ~/.kde/share/config/amarok* and~/.kde/share/apps/amarok/.

I'm now observing the following behaviour. In ~/.kde/share/config/amarokrc is the following entry:

[Collection Folders]
1=./mnt/myMusicMount
Use MusicLocation=true

Checking the SQL tables the 1 seems to be referred as some folder ID. If I start amarok it creates a new entry 4=./myUserName. If I go to the options I can see that only my home folder is selected as the default. If I add my mounted folder it creates another entry 6=./mnt/myMusicMount. It seems to be ignoring the entry 1 (which by the way doesn't disapear) completely and making it's own thing. I guess that's why it's ignoring the tracks referred by 1 in the DB.

share|improve this question
add comment

1 Answer

You've four out-of-the-box and graphical ways to access a remote amarok's collection:

And one way to configure properly a remote database.

Only one of the five solutions it's necessary.

share|improve this answer
    
I was aware of those solutions. They don't solve my concrete question. The first four only share the files, not the saved meta information. Ampache does a little but I tried it once and it is not really good. As I have written in my question I already set up a remote database and my problem is to access it's data from more than one client. –  André Stannek Jan 26 '13 at 10:50
    
I know what you mean, didn't appear the covers when you navigate through the collection, only did when you play the song. It's the normal behaviour (i have a similar configuration with a nas and different clients: xbmc, amarok, itunes, wmp), i had assumed it won't work as you (and me) want. –  n00b Jan 26 '13 at 11:16
    
Are you talking about Ampache in your last comment? ;-) –  André Stannek Jan 26 '13 at 12:10
    
nope, in fact i never used it ^^'... but i try with UPNP, Samba, DAAP, NFS also with iTunes "home sharing" settings and in the client never shows the covers of the albums as we assume it has to do, it's a weird behaviour but it's what i could archieve until now. Only xbmc works as i think you want and it don't use the metadata of the album (use a file folder.jpg in the directory of the album as cover) and is not an useful client to use. –  n00b Jan 26 '13 at 13:47
    
I have my id3 tags clean and complete including covers. That's not what I'm referring to when I say "metadata". I mean the ratings, playcount etc. Those would get lost across multiple clients using one of those methods. –  André Stannek Jan 26 '13 at 14:07
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.