Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've been living with this problem for quite a while now and I'm starting to get more and more frustrated as I work.

In all of my command line interfaces on Windows 7 (powershell, cmd, git bash) whenever I type in the console what I type will slowly, letter by letter appear. Each letter showing up about half a second after the last.

I type at a slightly higher than normal speed, and on my other computers the CLIs respond to my input just find. Every time I hit a key the letter comes up right away. When I'm running the CLIs other program are running fine, typing within other programs is not slow to respond at all.

This is very frustrating, because typing a command can take less than a second, but waiting for the command to 'finish typing' and then execute can take significantly longer.

I have tried:

  • Disabling UAC
  • Running the command as adminstrator
  • Closing all other running program
  • Restarting and having only a CLI running

I have tried finding answers all over the internet, but I feel that there is a name for the problem of which I do not know.

Update: While I was trying to figure out exactly what this was affecting I found out the following. If I hold down a button within my CLI and then go into another program before it is done completing all of the keyboard inputs and then scroll my mouse wheel in the new program I get Windows beeping at me. I think the Windows beep is the same beep as the when you try to give too many inputs to Windows, not entirely sure though.

Update: Looking at the Task Manager I can see that whenever I enter a command the process usage jumps by almost 30%...

share|improve this question

migrated from stackoverflow.com Jan 21 '13 at 14:14

This question came from our site for professional and enthusiast programmers.

    
I don't have that problem unless I'm typing 100letters a second(which I don't). Have you tried the solutions listed here? tomshardware.co.uk/forum/… Closing Office software, language bar settings etc.. –  Graimer Jan 17 '13 at 23:49
    
I have tried those solutions and they do not work. –  BZMWillemsen Jan 17 '13 at 23:54
    
ive seen other people complain about this issue with powershell before... not sure about a solution. –  Keltari Jan 21 '13 at 14:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.