Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a quad-core MacBook Pro (8 threads total) and once a week I am forced to wait about 5-7 minutes while the entire system becomes effectively unresponsive. Multi-tasking is basically unavailable at this time.

git tells me it is using 8 threads. How do I tell it to use less than that?

share|improve this question
up vote 8 down vote accepted

Set the pack.threads configuration option to a value between 1 and 7, inclusive.

For example, if you wanted git to use 6 threads instead of 8:

git config --global pack.threads "6"

Alternatively, edit the .gitconfig:

[pack]
    threads = 6
share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .