Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have an unusual problem effectively connecting all of the computers in my house.

1.) Win 7 Ultimate / Dell Inspiron N4110
2.) Win 7 Home Premium / Dell Inspiron N4010
3.) Win 7 Starter / Acer Aspire One Netbook
4.) XPSP3 (a) / Custom PC
5.) XPSP3 (b) / Custom PC
6.) Win 7 (School Issued) / HP Flip Screen Laptop

1.) Has no problem sharing anything in either direction with the other 5 computers.
2.) Can only see the Win7 PCs, but can only share with #1.
3.) Can only see and share with #1.
4.) Can see all, but only share with #1 and #5. (Can share in 1 direction with problem PCs)
5.) Can see all, but only share with #1 and #4. (Can share in 1 direction with problem PCs)
6.) Can't see or share with any of them. (But hey! got the printer working!)

I can add the shared printer on #4 to the unsharable PCs, by doing so using the IP and printer name.

i.e. \192.168.#.###\PrinterName, but not by browsing to, or using the PC name. (Adding the name and IP to the hosts file of the client PC allowed using the name, but still not browsing.)

Adding the IP and names to the host file of each PC helped only as far as using names manually, and pinging goes - but the PCs are still not browsable in the normal fashion - and passing documents between them is still only possible via flash drives or email - or as it currently works, mapping them manually to a drive letter.

I was only able to map drives on the Win7 machines to access XP shares, but not in the other direction.
This was not needed on Win7 machine #1, as it worked normally, so there was no point in trying.

PC #1 and #3 Both have home groups turned on, the other Win7 PCs do not.

My initial issue was with the printer, but I quickly worked around that (kids' need it for school). Although, the longer I messed with it, the more that I realized that we need full capacity sharing - no work arounds (flash drives, mapping, etc.).

The command net view returns an error 6118 on PC #2 and #3, but returns the names of all connected PCs, on #1, #4, and #5.

nbtstat -n had XP machine #5 list as the master browser, turning it off made it skip to #4 - the next step is turning this machine off (#4)... and see what happens...

Got the master browser to jump to #1 - now #3 can freely browse all but #2, #2 can't browse anything, and the XP machines still can't browse #2 and #3.

(#6 is at school with my daughter, and a non-issue, because it only needs to print)
(#1, #2, #3, and #6 are all laptops, and the likelihood of any of them being the "master browser" for any length of time is slim.)

net view will sometimes throw an error 53 on #3, until I ping something by name, then it goes away - showing the whole list as it should.

Additional info: same Work Group - same admin account on each but the school issued PC - turning HomeGroup off changes nothing - if clicking on the PC icon does not work, neither does \machine name (adding to the hosts files helped as far as resolving the name manually) - all of the laptops get turned off periodically, for extended periods of time - the XP machines are always on, with an occasional restart - so far, sharing the XP's printer is the only thing that works 100% across all.

I left out the obviously basic stuff expecting them to be assumed...


Reducing the issue to just 2 PCs - Win 7 Starter laptop and XP Pro Desktop (a).

Win 7 Starter

Currently the Master Browser
Can browse XP Pro with the mouse through "Network"
Can ping XP Pro by name and IP
Displays XP Pro in netview, as well as netview \IP and netview \name

XP Pro (a)

All of the above works on this machine except

The plain net view command and net view \name, both throw an error 53,
and clicking the "Workgroup" icon in "Network Places" now tosses the "path was not found" dialog.

The big difference being, that my daughter just took off, out of town, with the Ultimate laptop (all worked best when it was the Master Browser, and the Ultimate 7 still worked, even when it wasn't Master.)


At some point in time, the Master Browser jumped to the XP Pro machine:

XP Pro can now ping the Win 7 Starter machine by name now,
Win_7_S now shows up in XP>net view,
XP>net view \Win_7_S_name throws an error 53
XP>net view \Win_7_S_IP displays shares on Win_7_S
XP still cannot browse to this Win 7 machine, but it can to the other PCs again.

share|improve this question
    
My guess is that it's not a Master Browser problem. I see HomeGroup membership helps the Windows 7 (not available for XP). What about the Workgroup setting? Is it the same for all? Do all machines have one user in common with the same password? (preferably an administrator) So that you can try connecting with #\\machineName in both directions? –  Guy Thomas Jan 21 '13 at 19:14
    
@Guy Thomas - Changing master browsers reduced the problem, HomeGroup made no difference "on or off". Work group setting do not matter, but yes, they are the same. I have an admin account on all but the school issued PC. duh... really? Sorry, but not helpful - thanks for the newbie questions though... really insightful. –  tahwos Feb 4 '13 at 9:02
    
@tahwos - how are you sharing the drives / folders - because you have a mix of OS 'levels' (ie Pro-type and Home-type) the sharing options are different on each. 'Home' OS versions only support Basic sharing. Additionally, you need to ensure that you've not got Network Discovery turned on (for all), and that all versions support the level of encryption you've selected -- it's been AGES since I used XP, so can't remember if it supports the Win 7/8 128-bit encryption for file/folder sharing. –  PJC Feb 4 '13 at 9:37
    
Apparently my comment got deleted... maybe it was a little harsh, but @PJC your post is not helpful. –  tahwos Feb 6 '13 at 18:48
add comment

1 Answer 1

I reinstalled Windows 7 Starter, from the recovery partition on the Netbook. It now offers a User Login Dialog, from the remote PCs, that allows user level access to all files on the Netbook - shared or not.

(Provided that I know a user name and password on the Netbook.)

The remote PCs do not have to have matching User IDs/Passwords, admin accounts, or even be on the same network/workgroup - only be attached to the same physical router (wired or wireless).

Whatever the issue was, is now gone, and if I happen across further details, I will post for posterity's sake. My main goal was to be able to drag and drop files at will, both to and from, the Netbook via my main XP machine - I can do that now, with greater capacity than expected.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.