Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Something very funny is going on with my External Hard drive Caddy. I am running Linux Mint 14.

I had a laptop breakdown just before Christmas, removed the drive and placed it into a 2.5" SATA caddy, verified the data was there - no read operations, removed the drive, tried to access it days later to find the ext3 filesystem was totally corrupted. I assumed that was a disk issue.

I recently used the same caddy with an NTFS disk, data was fine, unmounted the disk, checked it days later, disk is entirely unreadable

So just now I checked it with a 3rd, old hard drive. Read the data, all fine, unmounted, reinserted, disk unmountable.

Any ideas what on Earth is going on, and more importantly how I can get the data back? it must still be there

share|improve this question
    
Are you certain that you are unmounting/ejecting the disk properly before disconnecting it? If the power is suddenly removed from these disks it can cause the issues you are describing. –  Will.Beninger Apr 29 '13 at 0:30
    
I'm definitely unmounting beforehand, but I've run out of disks to test it on, and I'm thinking this caddy is just going in the bin... –  Christian Mayne May 7 '13 at 11:32
    
How large were the drives? Were they more than 128GB in size? –  ppeterka Oct 11 '13 at 20:58
    
Yes, around 500GB I think –  Christian Mayne Oct 15 '13 at 9:18

1 Answer 1

Have you tried a different brand of caddy? Might at the very least possibly get data back... There may be something wrong with the controller in that one, and if there is, the data maybe gone anyway, as it most likely never made it to the disk.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.