Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I need to install fcl which depends on libboost-dev. However, libboost-dev depends on libboost1.46-dev and it refuses to install because I have the newer libboost1.48-dev.

I have followed instructions in the answer to this question: apt and fixing incorect dependencies. However, I'm unable to run debuild -uc -us successfully. This is the output:

 dpkg-buildpackage -rfakeroot -D -us -uc
dpkg-buildpackage: export CFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export CPPFLAGS from dpkg-buildflags (origin: vendor): -D_FORTIFY_SOURCE=2
dpkg-buildpackage: export CXXFLAGS from dpkg-buildflags (origin: vendor): -g -O2 -fstack-protector --param=ssp-buffer-size=4 -Wformat -Wformat-security
dpkg-buildpackage: export FFLAGS from dpkg-buildflags (origin: vendor): -g -O2
dpkg-buildpackage: export LDFLAGS from dpkg-buildflags (origin: vendor): -Wl,-Bsymbolic-functions -Wl,-z,relro
dpkg-buildpackage: source package boost-defaults
dpkg-buildpackage: source version
dpkg-buildpackage: source changed by Steve M. Robbins 
 dpkg-source --before-build boost-defaults-
dpkg-buildpackage: host architecture amd64
dpkg-checkbuilddeps: Unmet build dependencies: libboost1.48-dev (>= 1.48.1)
dpkg-buildpackage: warning: Build dependencies/conflicts unsatisfied; aborting.
dpkg-buildpackage: warning: (Use -d flag to override.)
debuild: fatal error at line 1350:
dpkg-buildpackage -rfakeroot -D -us -uc failed

I currently have libboost1.48-dev installed and other 1.48 boost packages.

This link shows the source of the libboost-dev error:

What can I do to fix this?

Edit: After checking dependencies, I realized I could uninstall libboost1.48-dev and use libboost1.46-dev instead.

I accepted terdon's answer because I think it is still useful information.

share|improve this question
Are you sure you have the right version? It is complaining about libboost1.48-dev (>= 1.48.1) and boost-defaults seems to be – terdon Jan 21 '13 at 20:27
@terdon Synaptic says I have libboost1.48-dev version 1.48.0-3 – ehuang Jan 21 '13 at 20:31
Well, the error you are getting is asking for a newer version. It wants >= 1.48.1 and you have 1.48.0-3. 1.48.0-3 < 1.48.1 – terdon Jan 21 '13 at 20:32
@terdon Synaptic only has version 1.48.0-3. Do you know how to upgrade to a later version? Also, will the solution in… potentially poison my apt-get dependencies. – ehuang Jan 21 '13 at 20:39
up vote 1 down vote accepted

Right, the solution you linked to should not affect anything but the package you are rebuilding. At least, there are no system wide changes or edits to /etc/apt/sources.list.

As for the latest stable libboost, it seems to be You can download it (or a slightly older release to be closer to what you have installed) from the boost sourceforge download page and compile from source.

Alternatively, you can search where you can find a .deb for Depending on the dependencies (no pun intended) you will be able to install that with or without apt pinning.

share|improve this answer
Thanks for your help. – ehuang Jan 21 '13 at 21:51

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.