Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Hardware. Router Dlink DIR-615. Hardware Version: E4 Firmware Version: 5.10RU

What did I have? A static IP from ISP. The mode to be used by the router to connect to the Internet is set to "Static IP". Configured port forwarding of dozen servers via Dlink Virtual Server feature. Router listened port 80 of internal network (its configuration page), and redirected connections to dozen of ports (HTTP, FTP, SVN, etc.) of WAN interface to my desktop.

What changed. I changed the mode to be used by the router to connect to the Internet from Static IP to L2TP (with static L2TP IP Address). L2TP doesn't belong to ISP. I have access to the Internet now as before. But Virtual Server feature doesn't work at all. When I try to connect to port 80 of my external (static, WAN) IP from my home network I get my router configuration page instead of my Apache HTTP Server root page, connections to other ports are refused. When I connect to any of my ports from outside my home network, connection is refused.

What did I try? When I switched back to Static IP mode everything worked great (except L2TP). Also I changed network address of my internal network from 10.XX.XX.XX to 192.168.XX.XX (I get IP like 10.YY.YY.YY from L2TP server, but with different mask), but without success. I also tried to sniffer if requests achieve server in my internal network, they don't. It looks like router just tries to process all requests forgetting that it should forward requests to another server.

What I need. I need L2TP connection with ability to receive requests to my services. So I need Virtual Server feature to work as before.

I tried to find the solution at forums, but failed to get any useful information.

share|improve this question
    
Have you tried accessing your services using the internal IP rather than the external IP? –  heavyd Jan 21 '13 at 21:34
    
Yes, when I use IPs of my internal network to access services (accessing directly to server that hosts them, without port forwarding) they works. –  Dmitriy Sukharev Jan 21 '13 at 21:37
add comment

Know someone who can answer? Share a link to this question via email, Google+, Twitter, or Facebook.

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.