Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I imported a bunch of frames as layers and did Filters → Animation → Optimize (for GIF). I got the layers transformed and delay applied to each layer’s name. In my case it is "(100ms)". But I’d wanted this delay to be 50ms, so I could then set specific delay for some frames manually.

share|improve this question

1 Answer 1

You can specify a default delay upon export of your gif.

Since this is a bit more tricky here is what you do, to reset all delays on each layer:

  1. Export your animation as a GIF. In the GIF Export Dialog, set the Delay between frames where unspecified to 50ms and export it to <yourname>.gif, e.g. test.gif.

  2. Tick the checkbox below labeled: Use delay entered above for all frames. This will reset the delay on all layers to 50ms.

  3. Import your GIF again. All layers should now state the 50ms delay. You can now set the custom delay on specific layers. Export the GIF again by using Export....

  4. Make sure you untick previous settings. This time you don't set anything and export it with the default settings.

Any additional details, are described in the documentation under File Formats.

share|improve this answer
    
Okay, you have 150 frames which GIMP marked as 100ms. You need all them to have a 50ms delay except the last one which must have 2000ms. Try to do that in export menu. –  tijagi Jan 22 '13 at 3:53
    
You will need to get rid of the optimisation, either by importing your frames as layers again or programmatically remove the delay in the layer name. Afterwards to can provide the non-default delay and use the export dialog. –  romanofski Jan 22 '13 at 4:03
    
"programmatically"? –  tijagi Jan 22 '13 at 4:40
    
"programmatically" meaning by using a script written in a programming language to "unset" all delays in the layer names. –  romanofski Jan 22 '13 at 4:45
    
Or answer or move that question to StackOverflow then –  tijagi Jan 22 '13 at 4:59

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.