Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

For editing the JSP files in the c: I have to run notepad and command prompt Run as Administrator every time. I am using windows 7 and only one user in the system. Can't I login to the system as administrator?

share|improve this question
add comment

migrated from stackoverflow.com Jan 22 '13 at 2:52

This question came from our site for professional and enthusiast programmers.

3 Answers

Maybe, this will help:

To mark an application to always run as an administrator, do the following:

1. On the Start menu, locate the program that you want to always run as an administrator.
2. Right-click the application’s shortcut, and then click Properties.
3. In the Properties dialog box, click the Compatibility tab.
4. Do one of the following:

    To apply the setting to the currently logged-on user, 
        select the Run This Program As An Administrator check box, and then click OK.
    To apply the setting to all users on the computer and 
        regardless of which shortcut is used to start the application, 
        click Change Setting For All Users to display the Properties dialog box for the application’s .exe file, 
        select the Run This Program As An Administrator check box, and then click OK twice.


You have to first open C:\windows\explorer.exe as Administrator. Then browse to this location: C:\Windows\System32\. Then right click Notepad.exe and change properties. Do the same for command prompt at location `C:\WINDOWS\system32\'.

share|improve this answer
Yes it is working for the installed applications, But it is not working for command prompt. All the options(compatibility mode, Settings, Privilege Level) are inactive. –  Sajeev Jan 10 '13 at 13:51
Updated answer... –  ATOzTOA Jan 10 '13 at 14:00
add comment

You should be able to run everything as admin by logging on as admin, and turning off UAC.


share|improve this answer
add comment

It sounds like you placed the .jsp files in a location where standard user accounts don't have write access by default. This includes the root of the C: drive... standard user accounts no longer have write access to the root C:\ folder. This has been true since Windows 2000 and Windows XP.

People have gotten away with it for a long time since then because so many run as an administrator account all the time, and so were able to write files to the C:\ folder anyway. Starting with Windows Vista, you know longer have administrator rights by default... even when logged in as the administrator account. Instead, to use your Administrator privileges you must use the "Run as Administrator" option on the context menu.

To get around your file editing problem, you can change the security permissions on specific folders where your *.jsp files live to allow your specific user account to have write access to that folder. You probably should not do this to the entire C: drive. Instead, move the jsp files to a folder you can use.

share|improve this answer
add comment

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.