Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I've made a small program to update our main product and made on option to start the program when windows starts. I've made this by writing the executing path of the application to the registry: LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Run\ and the path "C:\Program Files..." I want to use local machine so the program will start for all users loggin in to the computer.

I've tested this with some computers and all seems to be working just fine. But now we have three computers that doesn't work for some reason. Looking at regedit I can see that the program has added the registry entry correctly but nothing happens at start up.

What could be the cause of this or what should I check from these computers? These target machines are running windows 7 32 bit system.

share|improve this question

migrated from stackoverflow.com Jan 22 '13 at 3:28

This question came from our site for professional and enthusiast programmers.

    
Run Process Monitor and see why it is failing to execute; I am guessing the program requires elevation, and these will not run during Windows startup since it would be annoying to get prompted there. –  Luke Jan 15 '13 at 16:15
    
Yup, this was the reason. When putting the uac slider to the lowest category the program starts when windows starts. This is strange because I have administrator privileges and I've written the program to check these privileges before it writes the registry entry. So I can write the registry entry but it wont work :) I think I'll need to also check the level of uac before I allow the registry key to be inserted. –  japesu Jan 17 '13 at 13:28
add comment

3 Answers 3

I.First of all check that you really added it to startup. Go to
1) Start
2) Type "msconfig" => Enter
3) Go to "Startup" tab and check that your startup added correctly (and checkbox is checked)
II. Check path
III. Check that user has permissions to run that file

share|improve this answer
add comment

to add your program to startup for all users follow these steps. The all users Startup folder is a hidden system folder located at: C:\ProgramData\Microsoft\Windows\Start Menu\Programs\Startup 2. Open the Start Menu.

  1. Click on All Programs, right click on the Startup folder, and click on Open All Users or Explore All Users.

Drag the shortcut of your program to inside the Startup folder and drop it.

after this click start and type msconfig.check whether your program is added.

share|improve this answer
add comment

Given that the registry entry is visible in RegEdit, you could be a victim of Registry Virtualization.. Which you can turn off for that process.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.