Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I got a workstation here in a private network running Windows 8 Pro. This computer is used to test new features or Metro applications. The users connect via remote desktop and that works pretty fine so far.

My problem is now, that if a user is already connected to the workstation, he will be kicked off if another user connects. In older versions there was an option that the current user gets a message to accept or decline.

After hours of searching I couldn't find a solution for Windows 8. How do I solve this problem, or isn't it possible anymore?

share|improve this question
Have you tried to use gpedit.msc? -> Administrative Templates \ Windows components \ Remote desktop services \ Remote desktop session host \ Connections -> "Set rules of remote control of remote desktop services" (also Windows 7 does not do the asking by default) – Offler Jan 22 '13 at 8:53
Hey Offler, thanks for your post! I tried to change the settings at the gpedit.msc and it looked like the function i was looking for. Then i noticed that its only supported for: Windows Server 2008 R2, Windows Server 2008, Windows Server 2003, Windows 7, Windows Vista und Windows XP :-/ – EW72 Jan 22 '13 at 9:34
I tested it on Windows 8, and it worked despite what the notes say. I think a) Microsoft may not have updated the notes, b) 'Offler' is a genius! – Guy Thomas Jan 22 '13 at 12:00
Ok i made it work with Offner's tip (Big Thanks so far!) Now the problem occurs when i try to connect with the same account. But i guess there's no way to solve this or at least it makes no sense =). Thanks for help =) – EW72 Jan 22 '13 at 13:18

1 Answer 1

Windows 8 does not offer multiple RDP sessions out of the box. In older OS'es you could buy more Terminal Services (TS) Client Access Licenses (CALs) and Windows Server 2003 had two by default.

There is however a way to set up multiple RDP connections which I found in an answer to Super User question How do I enable terminal services on Windows 8?.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.