Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

In my house, I have the following setup:

  • Ground floor: My ISP's wireless router and an 8-port switch. For wireless communication I use the ISP's Wifi and the 8-port switch is used for wired rj45 sockets around the house.

  • 1st Floor: I have a TP-LINK TL-WR740N Wireless Lite N Router 150 MBps which I connected to a socket and have a PC connect with wire on it and also used for Wifi. The Wifi network I setup on the 1st floor is different than the one on the ground floor (2 routers).

At the first floor I have the problem that in other bedrooms far from the router the Wifi signal (either gets lost) or it's very low. So I bought a TP-LINK TL-WA701ND Wireless N Access Point 150MBps which I configured as universal repeater.

  • 1st issue: The access point supports only WEP encryption when used as repeater/universal repeater so I changed the wifi of the router to WEP with ASCII with 128bit character length and established the connection.

  • 2nd issue: The most important now is that even though the Wifi signal in the bedroom with the AP is full, when I switch off the wifi of the iPad and back on, it is not connecting to the internet. Yesterday I noticed that it was giving me the ethernet card IP (169.…). I went close to the router with the iPhone, got connected and when came back to the room with the AP it was working but the iPad is not working.

Can I fix this without having to buy any other hardware?

share|improve this question
add comment

2 Answers

I would start on scanning the Wifi channels near the bedrooms and near the two Wifi APs. You should check if they're in a different channel or are overlapping between the two floors. Also take note if there are other external Wifis that might be interfering with your home Wifi.

You can use inSSIDer to scan the Wifis. I'm sure there's also something similar for the iPad if you want to do the check from there.

Once scanned, you should change the Wifi channels to use the least crowded channel in order to get the most reception from it.

As for the issues, the first one is hardware based. TP-Link has some APs that are called Range Extenders, I think those are configured with one button only and support WPA2 without problem.

The second issue could be the iPad connecting to the TL-WA701ND, but this one couldn't connect to the main Wifi, that will give the iPad a wrong IP address if the DHCP is on that router or the one in the ground floor.

share|improve this answer
    
Thanks for the reply To let you know, the DHCP is on on the TL-WA701ND but the DHCP is disabled on the Access Point. What is the purpose of the DHCP server on the AP? It's purpose is to provide client (ipad, laptops, computers) with IP addressess or will it be changing the IP address on the AP? Should i enable DHCP on the AP? Repeating my self, DHCP is enabled only on the router on the ground floor –  user191962 Jan 22 '13 at 18:42
    
@AndreoyKyriakos You don't need to have several DHCP servers, just having one is fine, although you could have one per Wifi router to speed things a little (so the device doesn't need to ask the ground router if it connects to the 1st floor). As for the AP, if its in repeater mode, it doesn't have IP. It just acts as a range extender of the Wifi in the first floor. –  Peter Jan 23 '13 at 9:24
add comment

Part of your problem might be that your signal is still too weak. Turn off your repeater and check to see if you can get a stable connection to the router downstairs.

The repeater must be able to connect to the router for this to work correctly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.