Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a Dell Latitude e360 laptop (64-bit arch) that previously had 32-bit Windows 7 on it. Wireless worked beautifully on it. It has a slide button on the right side for manually turning the wireless card on/off.

Several months ago, I gutted the OS and switched this over to a 64-bit Ubuntu 12.04 (Precise Pangolin) system. When I did this, my physical workstation had changed such that I no longer really needed wireless - instead I was at a desk and always had a wired connection.

I'm now back to working from home and this morning tried using wireless for the first time in months. I have other laptops (also Ubuntus) that see my wireless router and home LAN no problem. But this machine doesn't show any wireless networks. In fact when I go to Network Connections, the Wireless tab is disabled altogether. So I looked down and noticed that the blue "wireless LED" was not on. I slid the wireless button to both the on and off positions several times. Nothing.

The way I see it is that I either (somehow) busted my wireless card at some point in the last several months, and didn't notice it because I was always at a desk using a wired connection. Or, perhaps there's something at the system level that is preventing wireless from turning on? What's my next step here? Thanks in advance!

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Is the wireless still enabled in the BIOS? Most laptops can enable/disable it from there. That same setting is usually tied to the physical switch, but utilizing that part may be Windows OS-dependent, and thus not available with Linux.

You may want to look up the specs for your specific wireless card and see if there is a Linux driver for it. Possible that it wasn't automatically recognized during your OS install and just needs to be manually installed to work.

share|improve this answer
    
Thanks @techturtle (+1) - I'll definitely try these suggestions by the end of the day and get back with a response. Thanks again! –  pnongrata Jan 22 '13 at 20:12
    
I added an answer showing exactly how I fixed my problem, but am giving you the green check for pushing me in the right direction! Thanks again! –  pnongrata Jan 22 '13 at 23:06

I fixed this myself:

sudo apt-get install bcmwl-kernel-source
sudo modprobe wl

Turns out the device driver for my wireless card was never installed.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.