Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Using Asus P5Q Pro raid5, (ICH10R chipset).

I've setup 4 SATA drives in Raid 5 using the motherboard's interface. It shows up in windows fine, without adding software. I've been using them fine for a while.

When I boot to ubuntu (9.04) the drives show up as individual drives. fdisk -l shows them as /dev/sda1 to sdd1, and gparted lists them as "unallocated".

(Ubuntu isn't booting from the raid install; it uses a different drive)

Surely if it's hardware raid ubuntu shouldn't be able to see individual drives, and if it's software I'd have needed to install some software on windows?



Edit: I installed dmraid on linux. /dev/mapper now contains an entry "isw_caajecghbe_Array".

dmraid -r shows
/dev/sdd: isw, "isw_caajecghbe_Array", GROUP, ok, (number of sectors), data@ 0
/dev/sdc: isw, "isw_caajecghbe_Array", GROUP, ok, (number of sectors), data@ 0
/dev/sdb: isw, "isw_caajecghbe_Array", GROUP, ok, (number of sectors), data@ 0
/dev/sda: isw, "isw_caajecghbe_Array", GROUP, ok, (number of sectors), data@ 0

dmraid -ay says the raid set is already active.

fdisk /dev/mapper/isw_caajecghbe_Array gives "unable to read"

For the benefit of searchers, this person has an identical problem, only with a slightly different chipset; http://ubuntuforums.org/showthread.php?t=1289290

share|improve this question
    
dmraid is the solution here, it's a tool to allow linux to use 'fakeraid' drives...but I have no experience with it, so I can't offer much other advice. – davr Oct 12 '09 at 16:42
1  
PS: If you haven't actually solved the problem, you shouldn't mark an answer as accepted – davr Oct 12 '09 at 16:43
    
Well, I consider the question answered. Unless someone actually finds a driver I don't see what more can be done. – RJFalconer Oct 13 '09 at 0:03
    
Hey hey, an upgrade fixed it. Awesome! – RJFalconer Nov 4 '09 at 23:44

Hardware RAID requires a disk driver for the OS. Apparently the Ubuntu kernel does not come with the driver for the ASUS motherboard. You might find what you need at the ASUS site.

share|improve this answer
    
Isn't the whole point of hardware raid to hide the raid system from the OS? Why is it that windows handles it without a driver? Is there some kind of bundled generic driver windows comes with? Or is my motherboard is actually using this "fakeRaid" I've come across? – RJFalconer Oct 12 '09 at 12:31
    
The point of hardware raid is to be fast and take load off the CPU. Like advanced video cards, though, they still need drivers. I presume that the ASUS chipset is supported natively by Windows, like most common hardware, but I haven't actually looked it up. – CarlF Oct 12 '09 at 15:59
    
Thanks very much for clearing that up for me. So there's no point me fiddling with linux settings at all until I have a driver? – RJFalconer Oct 12 '09 at 16:20
2  
This is not true hardware raid...it is what is known as "FakeRaid", 99% of the raid capability is provided by proprietary windows drivers. True Hardware Raid cards are much more expensive, several hundred dollars at least. As far as I know, 100% of on-motherboard raid is not true hardware raid. – davr Oct 12 '09 at 16:41
up vote 1 down vote accepted

Ubuntu 9.1 (Karmic Koala) now includes drivers for this as standard.

(Or at least, upgrading fixed my problem, woohoo).

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .