Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So I get five PCs with the very same hardware, I install all of them with Windows 7 Pro 64bits, and give each one a consecutive name (for example, PC1, PC2, PC3, PC4 and PC5) with group name GROUP.

We check they can connect to each other without problems, and that they connect to a test machine with XP Pro (by connect, I mean to see the network shares available) and here's the problem: when trying to see the XP shares, only one of them asks for a user and password in an imaginary domain named the same as the Windows 7 machine.

We have tried reinstalling the machine to no avail. It connects perfectly to Windows 7 machines, but it can't to the XP machines we have around.

UPDATE: It also fails to Windows 7 Home.

share|improve this question
1  
Firstly, it's normal to ask for MachineName\User. Do all the machines have the same user logged to test the connection? Exactly the same spelling? –  Guy Thomas Jan 23 '13 at 11:15

1 Answer 1

Windows 7 has the HomeGroup feature, that allows all the machines in the same group to share without prompting for the credentials. When you install for the first time a new machine and it detects the Home Group in your local LAN, it usually prompts you for the password to be able to connect to it. Once connected, it won't ask for other credentials.

Since Windows XP doesn't have this feature, it will work as other network shares, asking for the correct credentials.

You can check your Windows 7 Home Group options on Control Panel > Network > Home Group

share|improve this answer
    
Problem here is that there's no correct credentials, nor domain. The other four W7 Pro machines connect perfectly to XP. –  Saiyine Jan 23 '13 at 12:15
    
@Saiyine you could check the following then: All PCs are in the same workgroup and the PC that fails to connect has discovery enabled. You can check Discovery options in Control Panel > Network > Network and Sharing Center > Advanced sharing settings. –  Peter Jan 23 '13 at 13:11

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.