Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running iTerm 2 on 10.8 and I've installed zsh with oh-my-zsh and tmux (both from homebrew). When running zsh in iTerm it's all good, however, as soon as I run tmux, there is this weird distance between the margin and the cursor. What's weird is that once the command is executed, the distance disappears.

You can see it in the following screenshot.

enter image description here

Any idea what might be causing this? It's annoying ...

Thanks!

share|improve this question
    
What is the value of TERM both inside and out of tmux? –  chepner Jan 23 '13 at 19:58
    
Hmm ... outside of tmux is xterm-256color and inside is screen-256color. Which one should I change and how? –  Stelian Iancu Jan 24 '13 at 8:46
    
Found this issue as well, don't know if it's related or not: groups.google.com/forum/?fromgroups=#!topic/iterm2-discuss/… –  Stelian Iancu Jan 24 '13 at 10:45
    
Those are the same TERM settings I use. It could be an issue with your zsh prompt, in which case I'm afraid I can't help. –  chepner Jan 24 '13 at 14:15
    
Nah, it has something to do with iTerm2. With the exact same settings, it works fine in Terminal.app. However, there the colours are all messed up :-(. –  Stelian Iancu Jan 24 '13 at 19:59

1 Answer 1

I had the same problem, try

export LC_ALL=en_US.UTF-8
export LANG=en_US.UTF-8`

in your .zshrc so tmux will recognize you are using utf-8, also setting

set-option -g status-utf8 on
setw -g utf8 on`

might help.

as a last resort start tmux with the -u option for setting utf-8 this way

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.