Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to use Linux along with windows on my computer. My computer has Windows7 preinstalled. One day I went to installed Ubuntu on my laptop, the installation was successful and i suppose i had no problem on partitioning. Then I went on to reboot my laptop and tried to boot Ubuntu.

At first everything was fine. Then, suddenly the booting stopped. Nothing happened after that so I was forced to cut the power of my laptop to shut it down. I checked the installation, and even tried to reinstall it. No luck. I thought it was Ubuntu's problem. Then one day I wanted to try Chromium OS Lime. I successfully wrote the image into my usb. Then when I tried to boot the same thing happened.

I told my friend that my computer doesn't boot Linux so he gave me his USB stick to try to boot his backtrack. His backtrack boots normally on other computers, but still doesn't work with my computer.

Evidently Linux doesn't work on my computer. So my question is, what is making Linux not work on my computer and how do i solve the problem?

Besides, someone told me that my BIOS is forbidding non-windows OS, and another person told me it is something about the hard memory and something about SATA, but I know nothing about those.

share|improve this question
    
Does your laptop have BIOS or UEFI? Did any of the non-Windows OS install a GRUB or bootloader? –  Peter Jan 23 '13 at 16:28
1  
It possible that the Linux versions are trying to start the X Windows GUI and it's not working. When it stops, try pressing ALT-F1 and seeing if you get a text screen with a prompt. –  jwernerny Jan 23 '13 at 16:41
    
@Peter i used wubi.exe to install ubuntu. i think it did install a grub, but i dont think that is the problem. the booting process goes well until it suddenly stops. i mean it did actually boot, just that it stopped halfway and nev4er continued. –  busukxuan Jan 23 '13 at 17:01
    
It doesn't install grub in Wubi, it adds it to the longhorn loader (7's Loader). Did you see any verbose output as it's trying to load before it "stops" –  nerdwaller Jan 23 '13 at 17:29
    
What is your computer? I mean what make and model? –  terdon Jan 23 '13 at 19:46
show 3 more comments

2 Answers

Shot in the dark but have you configured the boot order in your BIOS? Make sure it is booting from USB 1st. Try using UNetbootin http://unetbootin.sourceforge.net/ select whatever version of linux you want to boot from and it should walk you through it all and boot from the USB automatically.

If that doesn't work and it is a problem with your BIOS try flashing it to an updated version. Go on Acer's website and try and find some updated flash and maybe that will fix it. Another thing you can do is just reset the BIOS by physically removing the battery from the motherboard and then putting it back in when the power is off and see if that fixes it.

share|improve this answer
add comment

It seems that that particular version of Ubuntu does not work with your computer. That does not mean that other Linux distribution would not work.

According to the symptoms I would tend to support @jwernerny guess. What graphics card do you have in your computer?

What I would do is trying a different Linux distro. You can either burn it to a CD/DVD and booting from it or write it to a USB key (FAT-formated, you will loose all the date in the key) by using something like Unetbootin, as previously suggested by @Kentgrav.

Which distro to choose, probably one that is not based upon Ubuntu. If, as it seems, the culprit is the GPU driver that Ubuntu is using,the problem with Ubuntu is that the black-box booting process will lead you to a blank screen without much info. Most other distros, if unable to start the X server, will drop you to a terminal. In the later case, you can be sure that the problem is just the graphics card driver and not something else. Furthermore, chances are that the driver used by other distro will work.

I would probably try with SystemRescueCD:

http://www.sysresccd.org/SystemRescueCd_Homepage

This will drop you into a console by default, then you can startx and see what happens.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.