Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

My girlfriend bought a laptop last week. It's a core 2 duo with 4 GB We installed vista 64bit, and one of the first things we did was right click on "My computer" to see gthe properties. Immediately we noticed something strange about her RAM, the line said: Installed memory (RAM): 4,00 GB (3,68 GB usable)

I told her not to worry, thinking it must be something about the laptop hardware (considering her vista installation came from the same DVD as mine, and I never noticed anything like that on my 4 GB desktop). One hour ago, it got worse. We looked at Properties again, and it now says: Installed memory (RAM): 4,00 GB (2,98 GB usable)

What does that mean? Are those 1,02 GB missing or being used by the system?

EDIT: There is a possibility that the sytem information is wrong. I just noticed that it reports an intel T6500 processor, when it's actually a T6400. How can I find out how much RAM is really available to the system?

EDIT2: Checking the resource monitors, it says 1003 MB are reserved for the hardware. Is that good or bad? Thanks

share|improve this question
    
Are you really sure that you've installed the 64-bits version? –  Wim ten Brink Oct 11 '09 at 21:52
    
Yes, absolutely. It is the same version I installed in my desktop, and I never had this problem. –  Bruce Connor Oct 11 '09 at 22:10
    
If the incorrect CPU is reported, it could be either the reporting utility is old, or the BIOS needs to be upgraded. –  kmarsh Oct 13 '09 at 12:32
    
could it be that I'v got the wrong driver installed? –  Bruce Connor Oct 13 '09 at 19:22
    

8 Answers 8

up vote 13 down vote accepted

Two possible reasons:

  1. the video card sharing RAM (using motherboard RAM instead of having its own, or using motherboard RAM to supplement its own)
  2. the motherboard chipset does not support remapping (the PCI architecture traditionally "owns" a chunk of the top Gb of the bottom 4Gb of physical memory, the remapping moves this above where your RAM is actually sitting so the two areas don't overlap). This is common with chipsets that only support 4Gb of physical RAM in total.
share|improve this answer
3  
Some more about chipset limits at this thread: superuser.com/questions/35731/… –  Chris_K Oct 11 '09 at 23:21
    
Also, don't forget about the 3 and change Gb limit on 32 bit machines. –  tvanover Nov 9 '09 at 18:30

The usual reason for this is shared ram with video.

Check in the BIOS and see if you can see / set how much memory the on board video uses - however I doubt it will be as much as 1GB and not sure where the rest can be (unless you have any sort of weird memdisk like utility)

share|improve this answer
    
Checking the resource monitors, it says 1003 MB are reserved for the hardware. That's a good thing right? –  Bruce Connor Oct 12 '09 at 21:01

How can I find out how much RAM is really available to the system?

You can use CPU-Z

share|improve this answer

Start > Run > Type MSCONFIG and click OK

Boot > Advanced Options

check wether maximum memory is capped.

share|improve this answer
    
The box is checked and it's set to 0. –  Bruce Connor Oct 12 '09 at 0:59
    
IF the box is checked then set it to the maximum available memory (i.e. 4096) ... or CLEAR the box. –  Molly7244 Oct 13 '09 at 17:05

BIOS shadowing, Video addressable area, and other memory mapped devices reserves memory between 640K and 1M and between 15G and 16G. The BIOS itself may remap (and therefor reserve) system memory into these areas for its own use.

In the end the O/S never gets 100% of the memory installed, but that doesn't mean it isn't getting used.

share|improve this answer
    
Well, as long as it's being used by the system, it's really ok. I was worried that it might not be used due to some bug or hardware deffects. –  Bruce Connor Oct 12 '09 at 20:59

I found a great explanation for this problem -- hardware is memory mapped -- at the following URL:

http://www.codinghorror.com/blog/archives/000811.html

share|improve this answer
    
Really informartive, thanks! –  Bruce Connor Oct 13 '09 at 0:43

I figured it out. After tinkering with it for a few hours, it turns out that the "Memory Reamp" needs to be enabled. On some Asus mobo's and a few other brands, when Win 7 is installed it recognizes that this problem. The problem was there all along and people just didn't know it until Win 7 was installed and pointed it out as a precursor to a BIOS problem that had been there the whole time. 1 Enter BIOS 2 Advanced 3 Chipset Settings 4 Enable Memory Reamp Feature 5 Exit and Save 6 You’re Done!

share|improve this answer

See this Microsoft KB article: The system memory that is reported in the System Information dialog box in Windows Vista is less than you expect if 4 GB of RAM is installed

For example, if you have a video card that has 256 MB of onboard memory, that memory must be mapped within the first 4 GB of address space. If 4 GB of system memory is already installed, part of that address space must be reserved by the graphics memory mapping. Graphics memory mapping overwrites a part of the system memory. These conditions reduce the total amount of system memory that is available to the operating system.

For Windows Vista to use all 4 GB of memory on a computer that has 4 GB of memory installed, the computer must meet the following requirements:

  • The chipset must support at least 8 GB of address space. Chipsets that have this capability include the following:

    • Intel 975X
    • Intel P965
    • Intel 955X on Socket 775
    • Chipsets that support AMD processors that use socket F, socket 940, socket 939, or socket AM2. These chipsets include any AMD socket and CPU combination in which the memory controller resides in the CPU.
  • The CPU must support the x64 instruction set. The AMD64 CPU and the Intel EM64T CPU support this instruction set.

  • The BIOS must support the memory remapping feature. The memory remapping feature allows for the segment of system memory that was previously overwritten by the Peripheral Component Interconnect (PCI) configuration space to be remapped above the 4 GB address line. This feature must be enabled in the BIOS configuration utility on the computer. View your computer product documentation for instructions that explain how to enable this feature. Many consumer-oriented computers may not support the memory remapping feature. No standard terminology is used in documentation or in BIOS configuration utilities for this feature. Therefore, you may have to read the descriptions of the various BIOS configuration settings that are available to determine whether any of the settings enable the memory remapping feature.

  • An x64 (64-bit) version of Windows Vista must be used.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.