Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

When I close the System Information window I get the following error:

Internet Explorer Script Error

An error has occurred in the script on this page.
Line: 86
Char: 1
Error: Object expected
Code: 0
URL: hcp://system/sysinfo/msinfo.htm

Do you want to continue running scripts on this page?

I then have to click Yes or No and the window gets closed. I can't say I'm having any malfunctions since System Information displays all the data correctly, I just get this error when closing the window.

Can anybody tell me what may be the problem? I'm running Windows XP Home SP3. If any other specs are needed, let me know.

share|improve this question

3 Answers 3

The following article supposedly applies up to IE6:
ActiveX controls may not load as expected in Internet Explorer
More info and a download of the fix here : Object doesn't support this property or method
Make sure to create a system restore point before updating the registry.

It would help to know what version of IE you have.

share|improve this answer
up vote 0 down vote accepted

I would also say it had something to do with the IE. I have just updated my IE (through Windows update) and now it's version number 8.0.6001.18702. Before that, it was also IE 8, just some earlier subversion (don't know which one exactly). Now the problem is gone. I just opened and closed my System information window and there was no Internet Explorer Script Error. That means, the problem was indeed inside IE, and the newest microsoft update seems to fix it. Having said that, I consider the problem solved :)

Once again, thank you for your replies!

share|improve this answer

This can happen if you have bad add-ons to Internet Explorer (which is used to render many features within Windows XP).

Go to Internet Explorer Options and try to disable / uninstall any addons that you think may be bad.

If this does not work -

  1. Go to Internet Options
  2. Go to the Advanced Tab
  3. Disable all the debugging options and click ok.

alt text

(May be slightly different under XP)

Be warned that this last option does not actually fix the problem, but it should suppress it.

share|improve this answer
    
Thank you very much for your reply. Unfortunately, it didn't work. I still get the message. Does anybody have an idea how to solve this permanently, opposed to just suppressing it? Thank you in advance! –  Sasha Oct 24 '09 at 13:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.