Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I written a script to take backup of svn repositories using command "svn-backup-dumps" But I am getting the error "svn-backup-dumps: command not found", Many forms suggests to install 'subversion-tools' to make this command works.

[root@localhost tmp]# uname -a
Linux localhost.localdomain #1 SMP Thu May 6 18:27:11 UTC 2010 i686 i686 i386 GNU/Linux

I downloaded package and tried to install , but it shows dependencies, Again I tried to install that particular dependency , again it shows another one ,, is there anyway to install all dependencies in a single shot ?

[root@localhost tmp]# rpm -ivh subversion-tools-1.7.7-1.fu2013.i686.rpm 
warning: subversion-tools-1.7.7-1.fu2013.i686.rpm: Header V4 DSA/SHA1 Signature, key ID 42d68235: NOKEY
error: Failed dependencies: is needed by subversion-tools-1.7.7-1.fu2013.i686
    subversion(x86-32) = 1.7.7-1.fu2013 is needed by subversion-tools-1.7.7-1.fu2013.i686
[root@localhost tmp]# 
share|improve this question

migrated from Jan 23 '13 at 17:03

This question came from our site for professional and enthusiast programmers.

Update : Looks like those are Fuduntu's packages! check over Fuduntu 13 mirror

Download all the dependency RPMs which are not yet installed, put them all in a folder and run your command. Listing RPM dependencies

If you know how to look in mirror sites: Fedora Mirror Sites

If you've setup package manager and have live internet connection then use it to install SVN for you. YUM - Fedora Package Manager

share|improve this answer

Fedora 13 is long end-of-life, you won't get any packages for that. Better update (but that probably means reinstalling from scratch). As you seem to have been using this machine with little change for several years, perhaps you should move to CentOS. As a RHEL clone it's management should be mostly familiar to a Fedora user. For stuff that isn't included in CenTOS proper, look at EPEL

share|improve this answer
up vote 0 down vote accepted

Downloaded subversion-tools-1.7.8-1.tar.bz2 and extracted that archive, then copied "svn-backup-dumps" to /usr/sbin , Now the issue is solved!!

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .