Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

We have about 80 systems running ubuntu 12.04 64bit desktop edition. We are facing a strange problem. Everything works fine except that after the monitor goes to sleep, if we don't wake it for long time then it stucks and won't wake up even if we keep pressing any key. But all tty consoles are working. Also i checked the syslog and it was showing the following warning message:

lightdm: pam_ldap: could not open secret file /etc/ldap.secret (No such file or directory)

Also if i pull out the power cable of monitor and insert it back (once the monitor LED goes from orange to black), the screen comes back and this time also the same above message is logged in the syslog. (The message may be totally unrelated to the error but since it was being logged by lightdm i didn't ignore it).

In pm-powersave.log i am getting the following line in the end /usr/lib/pm-utils/power.d/xfs_buffer false: not applicable.

Also sometimes the following message is being also logged kernel: [181899.744014] [drm] GMBUS timed out, falling back to bit banging on pin 6 [i915 gmbus reserved] kernel: [181901.504013] [drm] GMBUS timed out, falling back to bit banging on pin 0 [i915 gmbus disabled] about every 30 minutes.

Could someone please suggest what could be the possible reason for such a behavior?

update: we tried turning on the monitor through vbetool dpms on - didn't work. We also tried turning off acpi and apm through grub - didn't work! Power settings are set to never turning off the monitor yet it does go to sleep after like 10 minutes of inactivity.. the xset dpms is also on with blanktime, sleeptime, suspendtime and offtime set to 0 (never)

share|improve this question
    
Good question. I am having a similar problem, but without any message in the logs. I noticed the power cable has no influence on the result - if I try enough times, the monitor turns on even without touching the cable. –  choroba Jan 24 '13 at 9:03
    
The LDAP message is unrelated. You should disable pam_ldap if you are not using it. –  Julian Knight Jan 24 '13 at 22:09
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.