Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I just tried running a program installed through a .deb package and get this error:

error while loading shared libraries: libreadline.so.5: cannot open shared object file: No such file or directory

Does anyone know which library or package libreadline is a part of? If so, how do I install and make sure it is version 5?

Thanks!

share|improve this question

migrated from stackoverflow.com Oct 12 '09 at 0:19

This question came from our site for professional and enthusiast programmers.

    
I see the same error when running the command using sudo – Matt Norris Oct 11 '09 at 19:57
up vote 7 down vote accepted

There is a package libreadline5 in lenny: http://packages.debian.org/lenny/libreadline5

share|improve this answer
    
@kirushik - Thanks! Here is another resource mathlinks.ro/viewtopic.php?t=272131 – Matt Norris Oct 11 '09 at 20:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .