Super User is a question and answer site for computer enthusiasts and power users. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I use macmini to compile mac version of my program, I use ssh and vnc from linux, but problem is that I can only get either internet via wifi(en1) or local connection via ethernet(en0). if I do enable ethernet (en0) connection the internet is no longer working, although the wifi(en1) interface is still active. I suspect it is a routing problem. I have been trying for hours using route delete and route add 0.0.0.0 ..., netstat -na etc, but since I lack some knowledge my attempts lack consistency. I need both, lan for vnc and wifi for internet. VNC is slow over wifi and internet is required as well for some reasons.

lo0: flags=8049<UP,LOOPBACK,RUNNING,MULTICAST> mtu 16384
        options=3<RXCSUM,TXCSUM>
        inet6 fe80::1%lo0 prefixlen 64 scopeid 0x1
        inet 127.0.0.1 netmask 0xff000000
        inet6 ::1 prefixlen 128
en0: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        options=b<RXCSUM,TXCSUM,VLAN_HWTAGGING>
        ether a8:20:66:36:21:ea
        inet6 fe80::aa20:66ff:fe36:21ea%en0 prefixlen 64 scopeid 0x4
        inet 192.168.1.101 netmask 0xffffff00 broadcast 192.168.1.255
        media: autoselect (100baseTX <full-duplex,flow-control>)
        status: active
en1: flags=8863<UP,BROADCAST,SMART,RUNNING,SIMPLEX,MULTICAST> mtu 1500
        ether 88:53:95:2a:a2:89
        inet6 fe80::8a53:95ff:fe2a:a289%en1 prefixlen 64 scopeid 0x5
        inet 192.168.88.140 netmask 0xffffff00 broadcast 192.168.88.255
        media: autoselect
        status: active

Thank you very much!

share|improve this question

I shall try to guess at what the problem might be... As I'm probably going to state incorrect assumptions, please correct me, and I'll try again with the new information.

I assume both interfaces are being configured via DHCP. In that case, both your eth0 interface and your eth1 interface are receiving a 'gw' ip from their respective DHCP servers. Since the eth0 interface does not have a route to the Internet (a valid gw), whenever it is enabled, your connection to the Internet is dropping.

To make your Wi-Fi interface take precedence over the LAN interface, go into System Preferences..Network, and look for the gear icon in the lower left. Pull it down and select 'Set Service Order'. A new window will pop up. Drag Wi-Fi so that it's above Ethernet (or drag Ethernet so that it's below Wi-Fi), click OK to dismiss the service order window, then Apply in the main network window. This ought to give Wi-Fi a preferred status over your Ethernet connection.

share|improve this answer

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .