Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm on a network in India where it seems OpenDNS has taken over. I have experienced it for a few weeks now and I hate it with a passion. No longer do DNS queries fail as they should, but they return 67.215.65.132, which then goes redirecting to website-unavailable.com which is a low quality search page with deceptive advertising and a tiny message at the top saying "you tried to access X which isn't responding", or whatever the problem is.

I have tried changing the primary and secondary DNS servers to 8.8.8.8 and 8.8.4.4 (Google's public DNS servers) on the router and rebooting it. Ditto on the individual machines. But these don't seem to have changed anything. I presume the ISP is somehow overriding it.

C:\>nslookup broken
Server:  google-public-dns-a.google.com
Address:  8.8.8.8

Non-authoritative answer:
Name:    broken
Address:  67.215.65.132

This I really don't understand. What is OpenDNS doing? How can I get rid of it and return to sanity?

share|improve this question

3 Answers 3

If your ISP is intercepting all DNS requests and redirects them to OpenDNS, 1st thing to try is to setup your own OpenDNS account, and from there in Advanced Settings you can disable this domain typo redirect.

If this doesn't help, OpenDNS have a tool called DNSCrypt. It encrypts all of your DNS requests so that ISPs and others can't see and consequently modify your DNS queries. That will allow you to use OpenDNS in its unmodified form and from there you can absolutely disable domain typo redirects.

share|improve this answer

Have you tried to change the DNS settings in the TCP settings of the PC, just to see if this helps. B.t.w. there is a test page on Open DNS, to see if you are using Open DNS or not.

http://welcome.opendns.com/

It is strange though that setting the DNS on your router did not help. Are you sure this router is used as the DHCP server for your PC? Greetings from a happy OpenDNS user....

share|improve this answer
    
I have already tried setting it on individual machines. No change. –  Chris Morgan Jan 24 '13 at 8:37
    
welcome.opendns.com says "oops!", but it is there (both tests, the phishing site and the domain misspelling, worked as OpenDNS makes them work). Sounds like its a queer mixture of the DNS values that it's been given and the ones specified by me. Very strange indeed. –  Chris Morgan Jan 24 '13 at 8:42

Your network administrator has locked down all DNS traffic and only allows forwarding to OpenDNS in order to reduce traffic to malware and phishing sites.

You will need to contact them to have the DNS redirection removed.

share|improve this answer
    
Who are you considering to be the network administrator? The ISP? –  Chris Morgan Jan 25 '13 at 3:33
    
I'm on a network in India is slightly ambiguous as that's always tended to denoted a LAN or company network separate from the Internet, at least for the last 25 years I've been working on networking. OpenDNS doesn't force you to use their services, so if it's your ISP, that is doing it, you need to contact them to see if they'll allow you to use someone else as your DNS provider like Google. It's not typical, so I kind of assumed it might be the administrators on your local network, unless this is a home network you're referring to. –  Fiasco Labs Jan 25 '13 at 3:54

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.