Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a host computer running Windows7 with a wired network and a wireless network. These are two separate networks with two separate dhcp servers.

I created an Ubuntu virtual machine in VMware Player with two network adapters. Now I would like to bridge the two network adapters with my two physical networks. Then I encounter a very nasty problem.

I selected the first virtual network adapter and I clicked bridged & replicate physical network connection state. Than I click on the "Configure Adapters" buttons and select the host adapter I want this virtual adapter to bridge to.

I selected the second virtual network adapter and I clicked bridged & replicate physical network connection state. Than I click on the "Configure Adapters" buttons and I see the host network adapter I selected earlier for my first bridge is selected already. I do not want that so I deselect that one, and select the other physical adapter. Before I start the machine I check the first one if I did not make any mistake, and I see the second physical adapter is selected!!! It seems to be a separate application that is not linked to separate adapters, but does the overall bridging...

Is what I want even possible? I can not bridge them both, because they will autoselect the physical adapter that has the connection up&running.

share|improve this question
add comment

3 Answers

VMWare Player 5 has addressed this issue. It is possible to select the preferred auto bridging from this version. However, old versions cannot handle this unfortunately.

share|improve this answer
    
I am using version 5 at the moment, but this is why I have the problem. In the past there was a vmnetcfg.exe to do this. I will keep looking for the solution. –  spambas Jan 24 '13 at 10:17
    
"Simply select the Network Adapter settings on the Hardware tab and click Configure Adapters. Then you can choose which adapter(s) you want VMware Player to automatically pick from when bridging. So you can select one specific adapter if you always want it to be the one VMware Player bridges to". This is what they say. Yes, you are correct about the vmnetcfg.exe. It is not included. –  Lasith Jan 24 '13 at 10:45
    
That is absolutely correct and at the same time my exact problem. I can select a preferred bridging adapter, but with multiple adapters I can't select one adapter for one virtual adapter, as there is only one vmnet0 to bridge to. Try it yourself. Create a net vm with 2 network adapters, then try to bridge one to your wired, and one to your wireless. It is not possible... I found the solution though by using vmnetcfg.exe, but I can't answer my own question for a few hours as this is my first superuser question in the stackexchange platform... (place your sigh here :D ) –  spambas Jan 24 '13 at 11:02
    
Well I tried that earlier of course but I am using workstation and other products, there were two workarounds. One was to fetch the exe from the workstation cab or to run rundll32.exe vmnetui.dll VMNetUI_ShowStandalone to get the exe up and running (running from installed folder). :D –  Lasith Jan 24 '13 at 11:22
    
I just tried the second suggestion, but can't get it to work. I get an error from rundll that the OS can't execute "%1", whatever that my be... –  spambas Jan 24 '13 at 11:39
show 8 more comments

FOUND IT! It is not a pretty one, but is works.

In older versions of vmware workstation an player there was a tool for configuring network adapters. It is called vmnetcfg.exe. In the newest version of vmware workstation it is still in the install package, but not installed anymore. To get it to work in my vmware player id did this:

Get the Program

I downloaded the latest version of VMware Workstation (400+MB). When it completed I opened up CMD and extracted the installer:

> cd \path\to\installer\
> vmware-workstation-versionyaddayadda.exe \e extractedfolder

Then I went to the extracted folder and opened core.cab with winrar. Somewhere in there hides a vmnetcfg.exe. I extracted it and copied it to my VMware Player install folder.

Running te program

I started the program. I had a VMnet0, VMnet1 and VMnet8 listed. I selected VMnet0 in the list, then clicked bridged and selected my wireless network adapter instead of automatic.

Then I clicked "Add Network..." and called it VMnet2. I selected VMnet2 in the list, then clicked bridged and selected my wired network card instead of automatic.

Adding the card to the VM

First I added the second virtual network adapter in the VMware player's machine settings. The first one I kept on bridged, and configured the wireless adapter as the preferred bridge adapter (my wired adapter is not clickable anymore).

I needed to add the card to the VM by hand. This meant I had to open the VMX file in Notepad or in my case another preferred editor.
In the VMX file I added two lines (if they already exist, replace them.)

ethernet1.connectionType = "custom"
ethernet1.vnet = "vmnet2"

I saved the file and started vmware player. In my network settings I see this now:

Network Adapter: Bridged (Automatic)
Network Adapter: Custom (vmnet2)

I started the Virtual machine, and it worked!

share|improve this answer
add comment

VirtualBox can do this, so unless you absolutely must use VMWare Player, this would be an alternative.

share|improve this answer
    
I have a lot of vm's already. Not looking to convert all those to use them in VirtualBox. Or is this very easy? –  spambas Jan 24 '13 at 10:18
    
VirtualBox can use the VMWare disk format. I didn't have too much luck with the import/export process of them both, so whenever I needed to convert from one or the other, I created the VM afresh in the new tool and used the old disk as it is. Of course the guest tools will need to be updated also. –  Stefan Seidel Jan 24 '13 at 10:36
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.