Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have the following copy and paste issue since yesterday. Probably it started when I was trying to edit a locked Excel-doc which i found on a shared server (that is - it was not created with my installed Excel). Similar but different from the thread Excel copy-paste is only copying as values, but I want it to copy formulas (which was related to Skype, which I don't have on this machine).

Steps to produce issue:

1. Suppose A1 is " = 1 + 1 ".
The sheet shows 2 in cell A1, as it should.

2. Click on cell A1 and press Ctrl+C in order to copy the cell.

3. Click on cell A2 and press Ctrl+V in order to paste what is copied.

4. ---> The formula of A2 is 2 and not " = 1 + 1 ".

What I have tried - without success:

1. Change "Calculation options" in the excel folder "Formulas" from "Automatic" to "Manual" and back again..
2. Restart Excel - starting a new doc.
3. Restart Excel - opening an old doc.
4. Paste special giving the paste alternatives Text or Unicode.
5. Google searches - it seems to be a common issue in particular it occurs for [Skype users][2] who have a special plug-in. 

2-3 above made it work for a while, but not for long (could it be a service ???)!

Edit Also, 4 is worthless because if I display the clipboard in order to show what is copied into the memory, then nothing but the value of the cell is displayed in the clipboard!

My environment:

  1. I remote virtual machine which use Win7 and Office 2007.
  2. I do not have Skype on the virtual machine (but I do have it on the local remoting computer)

Do you have any idea?

share|improve this question
1  
Just to clarify, you say the question you link to is similar, did you try the solution to it or do you not have the Skype add-in. –  Tog Jan 24 '13 at 10:55
    
@Tog Hi, yes - in the end of the post I described the environment. There is no Skype involved here. –  AD. Jan 24 '13 at 10:58
1  
@Tog Added that explanation to the link. Thanks! –  AD. Jan 24 '13 at 11:03
1  
Have you tried running Excel in Safe mode? –  James Jan 24 '13 at 16:15
3  
I presume you can (1) click on cell A1, (2) click in the formula bar, or press (F2) to edit in the cell, (3) select the entire contents of the cell, either with the mouse or by typing Ctrl+Home followed by Ctrl+Shift+End, (4) press Ctrl+C to copy the cell, (5) click on cell A2, (6) edit the cell (as in 2), (7) select the contents of the cell (as in 3), and (8) press Ctrl+V to paste. I realize it’s not a viable, long-term solution, but it’s a workaround –– and, if this doesn’t work, your problem may be worse than you realize. –  Scott Jan 25 '13 at 0:42
show 11 more comments

1 Answer

I had similar issues with background processes like synergy and other tools that mangle with clipboard contents. Alt-tab twice does the trick here, back to normal clipboard behaivior.

And libre office calc seems to more robust with that problem.

share|improve this answer
    
Thanks for sharing. –  AD. Feb 18 '13 at 17:23
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.