Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So heres my set up. The picture isn't "Exact" I have modified it, but it gives you an idea.

enter image description here

The tools I am using are:

  • PUTTY
  • OpenSSH
  • CYGWIN
  • Remote Desktop
  • VMware vCenter Server Version 5.1.0
  • vSphere Client Version 5.1.0

Another thing I might note is that the machine DEVILSMILK and DUCLAW are Virtual Machines. KENT-PC is my physical machine with Administrative access to the domain where all 3 machines reside in the same local network 10.0.10.0/24. Also here is a list of the Operating Systems running on each machine:

  • KENT-PC - Windows 7 Ultimate
  • DEVILSMILK - CENTOS 6.3
  • DUCLAW - Windows Server 2008 Datacenter

Steps I've taken thus far with SSH:

  • On DEVILSMILK I am running OpenSSH as my SSH server and have disabled iptables so all ports are open.
  • On DUCLAW I am running OpenSSH via CYGWIN and rules have been made to allow access to Remote Desktop as well as port 22 for SSH.

My first machine KENT-PC at 10.0.10.110:RHP(Random High Port) is SSH'd into DEVILSMILK at 10.0.10.113:22. DEVILSMILK at 10.0.10.113:RHP is SSH'd into DUCLAW at 10.0.10.130:22. All connections have been made successfully and are logged in.

SSH Tunneling Configurations on PUTTY:

  • KENT-PC - L33389 localhost:60666
  • DEVILSMILK - L60666 localhost:3389

Now with all these configurations set and SSH connected successfully from end to end I then initiate Remote Desktop from KENT-PC and try to connect to localhost:33389.

Remote Desktop should then attempt to connect to KENT-PC at at port 33389 which will then be forwarded to DEVILSMILK on port 60666 which is then forwarded to DUCLAW on port 3389 (Remote Desktop Port) and the connection should be established and it should work, and I will have tunneled Remote Desktop through an encrypted SSH tunnel.

But it doesn't.

The error I get from Remote Desktop is:

This computer can't connect to the remote computer.

Try connecting again. If the problem continues, contact the owner of the remote computer or your network administrator.

Couple other things to note.

Remote Desktop directly to DUCLAW works fine with no issues, it just doesn't work through the SSH Tunnel.

Anyone know what I'm doing wrong?

UPDATE 1: Tried changing all the tunnel port numbers and hostnames to:

  • KENT-PC - L62333 DEVILSMILK:62334
  • DEVILSMILK - L62334 DUCLAW:3389

Still doesn't work. Also disabled the firewall entirely on KENT-PC...no go.

UPDATE 2: Tried using IP addresses instead of hostnames and that didn't work either. I also tried using port 3333 instead of 62333 for KENT-PC Localhost Tunnel port number and still the same.

share|improve this question
    
On KENT-PC, can you connect to port 33389 with telnet? What does that say? –  Tim Jan 24 '13 at 13:17
    
No I can't, it doesn't say anything. I turned off my firewall and then attempted to connect to 33389 with PUTTY on localhost from KENT-PC and the terminal window flashes and disappears. –  Kentgrav Jan 24 '13 at 13:21
    
Have you tried no tunnel or a single tunnel between a pair of {KENT-PC, DEVILSMILK, DUCLAW}? Can you connect to the RDP port itself from a remote machine, or from DUCLAW itself? What have you tried to isolate the problem? This problem seems very specific to your setup and is probably some configuration error. I'm not sure how helpful this is for others at Super User. –  Tim Jan 24 '13 at 15:01
    
As I stated above: "Remote Desktop directly to DUCLAW works fine with no issues, it just doesn't work through the SSH Tunnel". I can also RDP to DEVILSMILK just fine. What I can do however is try to tunnel to DEVILSMILK and see if that works and try to isolate the problem a bit more. –  Kentgrav Jan 24 '13 at 18:26
add comment

1 Answer

up vote 1 down vote accepted

Evidently there was some sort of issue with using the putty GUI to do the first SSH from Kent-PC to DEVILSMILK. A user on the /techsupport subreddit recommended that I use CYGWIN for all my machines. Sure enough after installing CYGWIN and using these commands:

ssh -vg -L 3333:localhost:6666 misfitred@devilsmilk

Connection Established.

Then from the same SSH console.

ssh -vg -L 6666:localhost:3389 kgraves@duclaw

Connection Established.

Then Run this command from KENT-PC which is my original host:

mstsc /v:localhost:3333

And Wahlah! As you can see in the picture below DUCLAW(10.0.10.130) is being accessed via Remote Desktop and as you can see in Wireshark it is an encrypted SSH connection that appears as if it is coming from DEVILSMILK (10.0.10.113).

I can now quit beating my head against the desk. Thanks to all who helped figure this out.

enter image description here

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.