Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When users access the vmware hosts on my server through vnc, the keyboard is not working correctly. In all other applications, e.g. terminal and openoffice, the keyboard works as expected: the keymap of the local client is used. Also, when I login in locally or through with a vnc client through vinagre everything is ok. I have searched the web extensively, but can't find a solution which works for all clients.

State of research:

  • xvnc consists of a x11 server with an rdp server to the client side. There are reports that xvnc has the us keyboard coded directly into the software. There is no configuration for this, as far i have found
  • the keyboard codes and keysyms are taking a long way: hardware -> client keymap -> vnc viewer -> rdp side of xnvc -> x11 side of xnvc -> server -> vmware -> vmware client One or more of these systems may perform their own mapping.

Client: windows and linux vnc clients (win:Realvnc and linux:vncviewer) Keyboard hardware: swiss german

Server: Ubuntu 12.04 LTS, xvnc started per client through xinetd

Vmware workstation: 8.0.2

Guest OS: Linux Debian 6.0

Problem: Keys like |, $, \ etc. don't work in the Guest OS.

Workarounds: Change keyboard to US on client os, access the guest os using vnc and change the keyboard map in every guest os.

Solution: Does anyone have a solution for this, which is not just a cludgy workaround?

share|improve this question

I had a similar problem with either key presses not being recognized or keys being repeated on an Ubuntu guest (running through Virtualbox) through a VNC session. I disabled "Repeat Keys" under the keyboard settings and this appears to have solved it.

I suspect some sort of incompatibility between VNC and the VM manager.

Good luck!

share|improve this answer
    
Thanks for the tip, I will try it out – Floyd Dec 1 '15 at 18:07

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.