Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I want to setup a PPTP vpn server on linux so that I can connect to and use the internet of the VPN on both Windows 7 and Mac OS X. I know how to create an SSH tunnel, but I would like to learn about VPN's.

The reason behind choosing PPTP is that I've heard it's relatively easy to setup but I've not had much luck in configuring.

The guides that I have been following mention about modifying /etc/pptpd.conf

and adding

localip <IP>
remoteip <IP>

However I don't understand the IP addresses that I should be putting in these?

The VPS that I currently has three network adaptors.

  • venet0
  • venet0:0
  • venet0:1

The last two I believe have the IP addresses that I have been allocated. so I am guessing in localip I should stick one of these... but as for remoteip I am unsure.

After following such guides adding the two ip addresses I have been allocated and restarting /etc/init.d/pptpd restart

I recieve this in Windows 7

enter image description here

Do I need to forward any ports on my router? or make any changes to my IPTABLES?

share|improve this question
1  
Keep in mind that PPTP is a totally broken and insecure Protocol that should not be used at all anymore. If you want to create a secure VPN instead of a vulnerability use L2TP, IPSec or OpenVPN with a proper configuration. –  MacLemon Jul 5 at 22:55
    
PPTP is insecure, don't use it. I suggest using IPSec with L2TP which is supported out of the box with Windows, on Linux you can use OpenSwan and xl2tp as the server. –  André Daniel Jul 5 at 23:42
add comment

2 Answers

up vote 1 down vote accepted

Both localip and remoteip are relative to the machine where the config file you put them in exist.

Therefore on your client that you want to connect from the following would be true:

  • localip would be the local ip address for the machine you are on (in this case, the client)
  • remoteip would be the ip address of the pptp server you are connecting to (in this case, the server)

Note that on the server these values would be reversed.

share|improve this answer
    
Would't localip be the IP of the server? as these configuration files live on the server? –  Malachi Jan 25 '13 at 10:28
    
Every VPN I've ever setup has a config file on both ends to handle dual NAT situations (where both endpoints are behind a router doing NAT); if you don't have a config file on the client (remember it could be hidden behind a gui on windows and not readily accessible unless you look for it) you won't know where to connect to. –  Jerry W Jackson Jan 25 '13 at 10:38
    
I managed to solve the problem after checking through /var/log/daemon.log I noticed that I was using the wrong remoteip and used one of the default ones that it provided. It works now :) –  Malachi Jan 27 '13 at 16:16
add comment

did you disabled mppe128 encryption on client side (you can done it somewhere in properties),

or keep it enabled and add one more line to your pptp config.

it must look like this

require-mppe-128
require-mschap-v2
refuse-pap
refuse-chap
require-mschap
refuse-eap
share|improve this answer
    
I will have a look at home/on my lunch break - currently at work. But thanks for the heads up. –  Malachi Jan 25 '13 at 10:29
    
yes regarding router, in case your server dont have "white" ip address, then you will need to redirect port 1723 from your router to PPTP box. on pptp box allow connections (iptables) to 1723 –  NauT Jan 25 '13 at 10:54
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.