Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I tried to install java 1.7 with rpm but got this error:

#rpm -i jdk-7-linux-x64.rpm. 
    package jdk-2000:1.7.0-fcs.x86_64 is already installed

If the package really was installed, then how come I still can't use java or javac command. Where is the package installed to?

Thanks

share|improve this question

1 Answer 1

Try rpm -ql jdk-2000 to see the list of files provided by the package jdk-2000 (hint: the rest of the package name given is the version and the architecture, so it's optional to provide it).

If it doesn't link java or javac to /usr/bin/, you can just create the symbolic links from /usr/<wherever>/.../java/ to /usr/bin/ using the ln command with the -s (symbolic link) flag.

It's probably already installed because you tried to install it once, tried the command, it didn't work, so you tried to install it again. Either that, or some other package you installed along the way (or some script you copy and pasted from the internet) installed the package for you. If you want to install the specific version of Java you have in that RPM, first remove the existing version with rpm -e jdk-2000 (-e stands for "erase").

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.