Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm running a brand new Asus RT-N16 with DD-WRT v24-sp2 (08/12/10) mega on it. Lately, I've seen slow transfer rates when moving files from my laptop to my server over wifi (laptop is using wifi, server is on lan). I'm currently transferring a 1.2GB file at speeds between 200kb/sec and 500kb/sec ... that's way too slow.

This is my first time running DD-WRT so I'm not sure what sort of information I can give (log files, command outputs, etc). If it matters, my laptop is running OSX and my server is Ubuntu.

share|improve this question
    
How fast was it before? What changed -- the Asus RT-N16? Does the laptop support 802.11n? Is the router configured for 802.11n with two channels? –  David Schwartz Jan 25 '13 at 4:13
    
@DavidSchwartz Everything changed: router and firmware. It used to be around 5-6mb/sec if I recall correctly. Yes, 802.11n is supported by my macbook. In DD-WRT my wireless network mode is set to 'mixed' on channel 6 (2.437 GHz) with a channel width of 20 MHz. –  maxmackie Jan 25 '13 at 4:31
1  
I noticed similar degradation in performance with TL-WR1043ND. I think that with all good features DDWRT brings in, it sacrifices one thing, performance. Stock firmware of my router delivers at least twice as fast wifi speeds than DDWRT was ever able to. It's either one or the other. Two pills. Your choice. –  Califf Feb 3 '13 at 16:39
    
As @DavidSchwartz intimated, using a channel width of 40 MHz could give you an increase in speed - similarly if its practical to drop mixed mode that could give you a performance boost as well. (I'm skeptical DD-WRT can't give maximum performance generally, and in the case of a WR1043ND which I have experience with), but It is conceivable its a driver issue for your particular device. –  davidgo Feb 16 '13 at 6:09
    
Also, it may pay to do some network analysis to see what channels are the quietest and shift to a quiter channel - or "Auto" if its available. –  davidgo Feb 16 '13 at 6:10

3 Answers 3

On the App Store, there are a few free Wifi apps that might assist in troubleshooting... (I myself have purchased WiFi Explorer when it was on sale, some months ago, and find it helpful in debugging other folks' wifi networks). This one seems rather cool: Wifi Survey (free) I have a mini, so it's not much use to me, but I'd have paid big bucks for something like that a few years ago for work. Something that's not altogether obvious is a verbose mode when holding down the Option key, and clicking the WiFi icon in the menu bar. It will then report the PHY mode, Channel, BSSID, Security, RSSI and Transmit Rate, which is something many of the free WiFi apps on on the store do, though a free app called WiFi Signal will give channel recommendations, should it detect overlapping signals from a neighbour.

share|improve this answer

If the problem goes away upon cold boot of the router. You are running out of resource within the router.

I used the same router. The problem goes away after I setup my own router (No WiFi) and change the Asus to a simple Access Point. Access Point needs a lot less resource and that's why it can work

share|improve this answer

1) why do you have the mega build? Any super functions you need? Put mini on if you don't need anything fancy.

2) ditch the mixed mode and choose n or ng, channel with 40MHz. Try above then below.

3) do NOT use chanel 6 try others. Best yet Go to status/wireless/survey and see which channels are free! You can use scanning soft from your laptop like inSIIDEr: http://www.inssider.com/

3b boost the power no more than 150mW or 23dBM: http://www.dd-wrt.com/wiki/index.php/Advanced_wireless_settings#TX_Power

4) Read up on your routers how-to maybe you forgot to disable something. SPI firewall disabled? UPNP disabled? http://www.dd-wrt.com/wiki/index.php/Asus_RT-N16#Current_Known_Issues_and_Bugs

5) if after restart problem disappears no biggie. Go to admin/scripts (can't remember where exactly) or was it cron? Anyways add a restart every 24-hours. Helped me once.

shutdown -r -f -t 0

6) In status check for cpu/ram usage. Se what peaks.

7)your router has broadcom chip what chip does your MAC wrl card have? Sometimes broadcom doesn't play well with atheros and vice versa in dd-wrt. Try another laptop. Try lan connection maybe there's something in the LAN wires.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.