Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I have a window 7 VB host, with wired and wifi. Normally, it is connected to my home net via a wire.

I have a a Debian guest with two adapters configured: one id bridged, and one is host only.

When plugged in, my VM hits the internet without a second thought, but when windows is connected via wifi, the VM can no longer reach the internet.

I thought that VBox would be using the host as its internet gateway, so I don't see why connecting to the internet via the host should fail when the host is connected via wifi.

How do I configure Virtual box networking so that my VM can reach the net regardless of network medium?

share|improve this question
1  
Does VBox has special settings for bridged adapter? I mean, your host has two, and VBox uses LAN always. I believe, you may manually force it to use WiFi. –  Maximus Jan 25 '13 at 7:11

2 Answers 2

I believe that it is not a routing but rather wireless security issue. Something along the lines of wpa_supplicant only supporting one adapter(virtual or physical) at a time. Try disabling WIFI encryption (just for the test) and see it the guest would be able to connect while the host is connected via unencrypted WIFI.

share|improve this answer
    
Not sure I'm following you, I expect the windows host to be the internet gateway, and the VM to communicate via a "wired" connection to and through the windows host. –  Len Jaffe Jan 25 '13 at 18:48
1  
For the host to be the gateway - the guest network adapter type should be "NAT" instead of "bridged" –  Alex P. Jan 25 '13 at 19:28
    
Because bridged makes it possible for the guest to use/share the hosts NICs as if they belonged to the guest? But can I assign the guest's IP (so I can hit the web services on the guest without adjusting the host file every time) ? –  Len Jaffe Jan 25 '13 at 21:03

I was even dumber then I thought. Once I added a Wifi nic to the host under virtual box, and brought the wifi adapter up under the guest, it worked. Sigh.

share|improve this answer
    
What did you do? VirtualBox has no concept of WiFi inside. –  guntbert Jan 13 at 21:07
    
I thought that having a bridged network interface would be all that I needed, but I was incorrect. In order to use the wifi nic on the laptop, I had to define it to virtual box and enable it on the guest. –  Len Jaffe Jan 14 at 14:11
    
What you should have done: tell VBox to bridge the virtual adapter to your WiFi adapter. –  guntbert Jan 14 at 20:23
    
I thought I had, but apparently not. –  Len Jaffe Jan 15 at 15:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.