Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

So tonight my Linux filesystem got corrupted somehow (bad superblock, all that). I booted into my live CD, attempted to fix it, then I rebooted to check. At the GRUB screen, somehow the option selection timeout disappeared (it was 10 seconds before, now for some reason it's been set to infinite).

I tried to hit Enter to boot into my filesystem, but then remembered I'm using a wireless keyboard which doesn't work in BIOS or GRUB for some reason, so I switched out for my trusty backup USB keyboard, which is supposed to work. But - of course - the keyboard no longer functioned.

So now I was stuck with an inert GRUB screen, and no way to access the BIOS to change the boot sequence either. What I did was physically disconnect my SSD (which contains the Linux filesystem) from my motherboard, such that the BIOS would fallback to the next drive in the boot sequence, namely my Windows 7 operating system.

Unfortunately, the GRUB partition was located on the SSD, so it seems I cannot actually change its timeout settings back to the original 10 seconds. In other words, I am stuck on this Windows system.

Because it's night, I cannot just go buy another keyboard, and I have important work to complete, so here comes my question: in order to get the GRUB timeout back, is there some way I can somehow:

  • change the BIOS boot sequence from within Windows

or:

  • connect the SSD while Windows is running (seems rather risky)

Losing all data on the SSD would not be catastrophic (all my documents are on another disk) but I would like to avoid any solution involving this, because setting up a completely new system takes forever.

I realize this is a really screwed up situation and a surefire way to fix it would be to just wait the night out and grab a new keyboard to get past GRUB (whoever thought an infinite timeout was a good idea) but if there is an alternative - no matter how insane - I will gladly take it.

The SSD itself is not damaged (all self-tests passed).

share|improve this question

2 Answers 2

If you can get a LiveCD to boot, then you should try putting GRUB on the harddrive which has windows - or if you have a Windows install disk, open the repair console and play with fixmbr (This may run into the same issue with lack of keyboard though, I don't know if the Windows install disk will have the drivers). Either way, once the disk is bootable, just boot the system with the live CD disconnected.

Also, won't the Live CD boot the first disk that it finds if you don't select an option within the timeout when its boot loader pops up? All the major linux distros that I've worked with will do this, and a Windows install disk will definately do this. Make sure that the Windows harddrive is the only drive in the system, and then see if the Live CD will boot it?

share|improve this answer
    
I can't boot into a Live CD because the boot sequence in the BIOS is SSD (Linux) -> HDD 1 (Windows) -> HDD 2 (not bootable - linux home drive) and I can't change it due to no keyboard. –  Thomas Jan 25 '13 at 15:51
    
Ah, I was confused because your second sentence indicated that you could boot into a live CD. If you can't boot into a live CD and it's critical to get the work done tonight, I'd start looking for a 24hr convenience store (CVS, Walgreens, etc.) and see if they have a cheap USB keyboard. You could also try factory resetting the BIOS if that would make it boot the CD before the harddrives. –  Darth Android Jan 25 '13 at 16:56
    
Yes, the backup keyboard worked once for the live CD, and then failed (call me unlucky..), should've clarified that, sorry. Resetting the BIOS, I believe the disk would boot before the hard drive, but I don't actually have a CD/DVD with a live CD on it (it's on a USB stick). I could burn it, though I have no writeable DVD lying around. It's dawn now, but I'll try and find a keyboard somewhere. Thanks for your help nonetheless - the work isn't critical but I did not expect my computer to 'fail' in this frustrating way (morale: you never have enough keyboards) –  Thomas Jan 25 '13 at 19:08

The problem - and solution - has been identified.It turns out there was a keyboard conflict between my wireless keyboard and the USB one, the BIOS defaulted to the wireless one which doesn't work. Disconnecting the wireless from the computer solves the keyboard issue. Now on to the drive issue...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.