Take the 2-minute tour ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I'm a semi-linux newcomer and i have a question:

I need to set some GPIO pins in this way: (pin 18 out, pin 17 in) (actually i'm doing this via WiringPi(python) trought this commands)

gpio export 18 out

gpio export 17 in

All Works fine if i run these commands via terminal. However i have set these commands in

/etc/rc.local

before exit 0

to run it at boot, but after some tryies it won't work. It could be a path problem? Any help is appreciated, Thanks mboy.

share|improve this question

1 Answer 1

up vote 2 down vote accepted

I've fixed it! All I needed was to set the full path.

In my case /usr/local/bin/gpio export 18 out because gpio is a third party command.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.