Sign up ×
Super User is a question and answer site for computer enthusiasts and power users. It's 100% free, no registration required.

I work with a dual display here at work. Now, this doesn't happen right at boot up, but once it starts, it doesn't stop until I reboot.

If I press 1 (non-num pad), it will move my window to my main display. If I press 2 (again, non-num pad), it will move my window to my secondary. If the window isn't full and it is already on the main display, it will snap the window to the center. The same applies to the secondary display.

Is there anything I can do to stop this? I'm not even sure why it happens. Like I said, it doesn't happen right when I boot up. I generally kicks in a few hours after I've been using them with no problem.

It's getting relatively annoying to have to follow my 1 and 2 keystrokes with a 1 and 2 to switch everything back.

share|improve this question
What operating system? This must be something specific running (I don't know of an OS where it's default behavior) so we need some idea of what this is attached to... – Shinrai Jan 25 '13 at 17:11
I'm working in Win7. – Maddie Jan 25 '13 at 17:33
Just stopping in, I had this issue turned out to be ctrl-alt being stuck. I actually routed the plug to the front of my workstation. I just replug it when it glitches out. Temporary fix for me while I figure out what's really going on. – Bmo Jul 23 at 10:49

5 Answers 5

Most likely you have one of two problems that are causing one or more modifier keys to get stuck in the "pressed" state.

  • Hardware key is stuck

Check all the modifier keys on your keyboard (Ctrl, Alt, Shift, Fn, Windows Key), both on the left and right side. Are any of them stuck in the "down" position? If so, there's your problem.

  • Software is keeping the key pressed down

This one is harder to track down. If you have some automation software that automatically sends key presses to automate tasks (AutoHotKey, Softmotive WinAutomation, etc.) this software may be malfunctioning and telling the operating system to leave the key in the pressed position.

If it's neither of these, it may be an electrical short in your keyboard, which sometimes causes keys to appear pressed when they're not, or causes one key to be "remapped" to act like a different key or key combination.

One interesting test that you can do is this:

  1. Boot your computer fresh.
  2. Press the "1" key on your keyboard, then the "2" key, and observe that doing so does not move your windows around (the software/hardware is working fine).
  3. Hold down the CTRL key and press "1" then "2". See if it moves your monitor.
  4. Repeat the above step with ALT, SHIFT, and various combinations of CTRL, ALT, SHIFT, and the Windows Key.
  5. If you find a reliable key combination that does move your windows, then you know that, whether it's hardware or software, something is causing those modifier key(s) to be held down.
share|improve this answer
I swapped out my keyboard, and still have the same problem. My boss had found a shortcut that was set up for CTRL 1 and CTRL 2 (before I ended up with a new keyboard), and he changed it to ALT 1 and ALT 2, which didn't solve anything. All in all, I've had 2 keyboards, I've changed shortcuts, and nothing seems to fix it. I will take a look at software, see if there's anything I can find, but nothing in my installed programs looks strange, and all of my keyboard settings are default. – Maddie Jan 25 '13 at 17:34

I started having a problem after our IT department set me up with a third monitor. They used a Startech USB to DVI adapter to drive the third monitor. I started having the problem where I would press the number 1 key and it would jump to screen one. Press 2 and it would jump to screen two. Press 3 and jump to screen three. Pressing the control key would get it to stop. I finally discovered that I could drive the third monitor using the VGA port which eliminated the Startech adapter but I still had the problem. I plugged the adapter back into the USB port and it started installing software. When it was done it said Trigger II drivers installed. I opened control panel, programs and features, and found the Trigger II driver program. It said the manufacturer was Startech, so I uninstalled the drivers. After I uninstalled the Trigger II drivers the problem disappeared for good. I think Startech must have a bug in their software. I hope this helps.

share|improve this answer
I had the same problem, just with control reversed. It is a 'helpful' extra feature to help move windows to the extra monitor, but nowhere you get asked if you want to add this needless part at all. Nor does it ask for which keys to use. (The default settings conflict with open office scal and with excel, so not fun). – Hennes Oct 21 at 20:33

I had the same problem and I tried Shift+2 and it moved to the other monitor but then I tried Shift+1 and it did not move back.

I then tried 1 only and it did not move back. I then dragged the open window to monitor 1 and hit 2 and it did not switch to the other monitor. I hit 1 and it did not do anything.

I do not know why this worked but it did so now I do not have to throw my PC through a perfectly good window.

share|improve this answer

I had the same problem. Solution: disable hotkeys from a program called Super Utility (or other third party software).

If you have this “Super Utility“, you can disable it like this: task bar (lower left, near the clock) -> show hidden icons -> Super Utility + second click -> Multi Display Control Panel -> Disable button -> save and exit.

A similar procedure with other screen managers should do the same trick.

I have a Lenovo yoga pro and it came with program called “Super Utility“. It manages shortcuts for different screens and sometimes it does not read the modifier keys properly. Sometimes pressing just a number 1 or 2 changes the window to another screen.

In addition, in my native keyboard “@“ sign is produced with alt + ctrl + 2, which was also the default shortcut (ctrl+2) for the second screen (this meant that all email was written in the second monitor). The funny thing about this was that this 'feature' came with an update, so originally it was working fine.

share|improve this answer

Hello we had the same problem. You can on Lenovo X1 and pressing 1 or 2 would switch the window to another monitor.

after replacing y our external keyboard I found it to be a software problem. So I went to the config panel / keyboard / and disabled the application shortcuts which solved the problem.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.